Bug 247495 - rtw88: RTL8821CE 802.11ac PCIe Wireless Network Adapter support
Summary: rtw88: RTL8821CE 802.11ac PCIe Wireless Network Adapter support
Status: Closed DUPLICATE of bug 248235
Alias: None
Product: Base System
Classification: Unclassified
Component: wireless (show other bugs)
Version: CURRENT
Hardware: Any Any
: Normal Affects Many People
Assignee: freebsd-wireless (Nobody)
URL:
Keywords: feature, needs-patch, needs-qa
Depends on: 248235
Blocks:
  Show dependency treegraph
 
Reported: 2020-06-23 08:22 UTC by Andrey P.
Modified: 2021-08-18 10:34 UTC (History)
6 users (show)

See Also:
koobs: mfc-stable13?
koobs: mfc-stable12?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey P. 2020-06-23 08:22:29 UTC
Please add support for RTL8821CE wireless PCIe card if possible.

Support for this device is critical to conquer market of desktops since this device is 11th most popular card this year after QCA9377, AR9285, AR9485, QCA9565, Intel 8265, Intel 7260, Intel 7265, BCM4313, Intel 9560 and Cannon Point-LP CNVi: https://linux-hardware.org/?view=net_model&search=wireless&period=-2

Thank you.
Comment 1 vidwer+fbsdbugs 2020-06-23 09:44:18 UTC
You should be (made) aware that, depending on where you obtain source code for this chipset from, _possibly_ an incompatible license applies.

See https://github.com/lwfinger/rtlwifi_new/blob/rtw88/rtw8821ce.c versus https://github.com/RangeeGmbH/rtl8821ce/blob/master/include/rtl8821ce_hal.h
Comment 2 Bjoern A. Zeeb freebsd_committer 2020-07-31 11:35:53 UTC
Seems the 8821C code was mrged into the official wireless-testing tree as well in the rtw88 driver with a dual GPL-BSD license.

So this will emerge as well with rtw88 (see PR 248235 for more details).
It is a while out, but I'll post something to test as soon as possible (if even just with abg[n]) support.
Comment 3 Bjoern A. Zeeb freebsd_committer 2021-08-18 10:34:02 UTC
I'll merge the PRs so there's only one to track.
Please follow the later 248235 and keep an eye on freebsd-wireless the next week or so.

*** This bug has been marked as a duplicate of bug 248235 ***