Bug 247512 - [NEW PORT] www/grafana7: Dashboard and graph editor for multiple data stores
Summary: [NEW PORT] www/grafana7: Dashboard and graph editor for multiple data stores
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: Kurt Jaeger
URL:
Keywords:
: 247053 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-06-23 21:55 UTC by Robson Mantovani
Modified: 2020-06-25 05:20 UTC (History)
3 users (show)

See Also:


Attachments
grafana7 (148.72 KB, patch)
2020-06-23 21:55 UTC, Robson Mantovani
no flags Details | Diff
New Patch (148.78 KB, patch)
2020-06-24 17:32 UTC, Robson Mantovani
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Robson Mantovani 2020-06-23 21:55:22 UTC
Created attachment 215895 [details]
grafana7

New port wwww/grafana7
Comment 1 Danilo G. Baio freebsd_committer 2020-06-23 23:36:23 UTC
*** Bug 247053 has been marked as a duplicate of this bug. ***
Comment 2 Kurt Jaeger freebsd_committer 2020-06-24 07:00:58 UTC
I tried this:

svn cp grafana6 grafana7
svn patch patchfile

but this did not work.

Can you give me a hint how your patch should be applied ?
Comment 3 Robson Mantovani 2020-06-24 17:32:40 UTC
Created attachment 215913 [details]
New Patch

Hi, 

I generate a new patch, i don't know what happened with the old one.

The steps to test are the same that you wrote. 

svn cp www/grafana6 www/grafana7
svn patch /tmp/grafana7.patch
Comment 4 Kurt Jaeger freebsd_committer 2020-06-25 04:33:38 UTC
Looks good!
Comment 5 Kurt Jaeger freebsd_committer 2020-06-25 05:20:06 UTC
Some small fixes in the Makefile to pet portlint done

Committed, thanks!
Comment 6 commit-hook freebsd_committer 2020-06-25 05:20:37 UTC
A commit references this bug:

Author: pi
Date: Thu Jun 25 05:20:03 UTC 2020
New revision: 540369
URL: https://svnweb.freebsd.org/changeset/ports/540369

Log:
  New port: www/grafana7

  Grafana is an open source, feature rich metrics dashboard and graph editor for
  Graphite, ElasticSearch, OpenTSDB, Prometheus and InfluxDB.

  WWW: https://github.com/grafana/grafana

  PR:		247512
  Submitted by:	Robson Mantovani <robsonmantovani@gmail.com>

Changes:
  head/www/Makefile
  head/www/grafana7/
  head/www/grafana7/Makefile
  head/www/grafana7/distinfo
  head/www/grafana7/files/grafana.conf.in
  head/www/grafana7/pkg-plist