Bug 247545 - Tenda W311Ma (Chipset mt7601u) Ralink but no support ???
Summary: Tenda W311Ma (Chipset mt7601u) Ralink but no support ???
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 12.1-RELEASE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-wireless (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-25 18:45 UTC by Mc James
Modified: 2020-07-02 01:00 UTC (History)
1 user (show)

See Also:


Attachments
windows driver INF file (829.54 KB, text/plain)
2020-07-01 21:23 UTC, Mc James
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mc James 2020-06-25 18:45:23 UTC
today after a failed  attempt here https://forums.freebsd.org/threads/tp-link-tl-wn823n-v2-device-not-showing-up.75923/ 
I went and bought a "tenda w311ma" which in freebsd froum was suggested and praised. but It is not working.

dmesg :

 ugen7.2: <MediaTek 802.11 n WLAN> at usbus7

this device is supposed to be Ralink RT5370 which I can't figure out what t is what I have.
do we have any support for this?
ugen7.2: <MediaTek 802.11 n WLAN> at usbus7, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON (160mA)
Comment 1 Mc James 2020-06-25 18:47:30 UTC
/boot/loader.conf >> 
if_run_load="YES"
runfw_load="YES"
if_ral_load="YES"
if_ural_load="YES"
if_rum_load="YES"
if_ral_load="YES"
and I can't to make it work

it is the exact picture of the device:
https://www.aliexpress.com/i/32692482931.html
Comment 2 Mc James 2020-06-26 15:53:21 UTC
the MT7601U is <<Chipset Ralink RT5370>> just a rebrand name.
and RT5370 is supported under freebsd for sometimenow. So if the devs do a bit of adjustment it will work.
Comment 3 vidwer+fbsdbugs 2020-06-26 16:10:50 UTC
(In reply to Mc James from comment #2)

What's the device ID? See https://github.com/freebsd/freebsd/blob/master/sys/dev/usb/usbdevs#L3947
You can retrieve this using the 'usbconfig' tool.

I could provide a patch, which ideally would land in -CURRENT so you will have to patch and recompile things manually.
Comment 4 vidwer+fbsdbugs 2020-06-26 16:13:03 UTC
(In reply to vidwer+fbsdbugs from comment #3)

https://github.com/freebsd/freebsd/search?q=rt5370&unscoped_q=rt5370
Comment 5 Mc James 2020-06-26 22:35:33 UTC
hello;
In debian this is what I have:
lsusb:
Bus 004 Device 004: ID 148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter
dmesg:
[   12.545023] mt7601u 4-3:1.0: ASIC revision: 76010001 MAC revision: 76010500
[   12.579310] mt7601u 4-3:1.0: firmware: direct-loading firmware mt7601u.bin
[   12.580842] mt7601u 4-3:1.0: Firmware Version: 0.1.00 Build: 7640 Build time: 201302052146____
[   12.992777] mt7601u 4-3:1.0: EEPROM ver:0d fae:00
[   13.250784] usbcore: registered new interface driver mt7601u
[   13.259271] mt7601u 4-3:1.0 wlx502b73e93f56: renamed from wlan0

usbconfig freebsd 12.1 amd 64 : 
ugen7.2: <MediaTek 802.11 n WLAN> at usbus7, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON


https://lists.freebsd.org/pipermail/freebsd-drivers/2020-June/002289.html
Comment 7 Mc James 2020-06-26 22:39:30 UTC
(In reply to Mc James from comment #6)
https://www.tendacn.com/en/download/detail-2515.html
Comment 8 Mc James 2020-06-26 22:41:40 UTC
In windows

Ralink Technology, Corp. MT7601U Wireless Adapter USB\VID_148f&PID_7601
Comment 9 Mc James 2020-07-01 21:18:26 UTC
I installed a windows XP in virtualbox. I went to install the drivers and the driver that worked in XP is rt2870. that is contradictory from what I see on the web.
I tried to ndisgen the driver, although the process was successful the driver will cause kernel crash after load.
I'll attach the windows file here.
BUT it changes nothing cause [[[[ rt2870 ]]]] is also supported from 2009 ....
Comment 10 Mc James 2020-07-01 21:23:39 UTC
Created attachment 216118 [details]
windows driver INF file
Comment 11 Mc James 2020-07-02 01:00:14 UTC
windows driver INF file

https://gofile.io/d/K8q1tG