Bug 247653 - mdmfs(8) -p option is no longer recognized
Summary: mdmfs(8) -p option is no longer recognized
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: Unspecified
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2020-06-30 07:43 UTC by Scott Bennett
Modified: 2020-07-02 05:04 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott Bennett 2020-06-30 07:43:48 UTC
In 10.3-STABLE the -p option, which allows the setting of the file system's
permissions, worked fine.  When I installed 11.1-STABLE and booted it, the
/etc/rc.d/tmp script failed with an error message about the -p option.  I have
worked around the problem by removing the option from tmpmfs_flags in
/etc/rc.conf and changing the permissions elsewhere once the memory file system
has been created.  However, the man page for mdmfs still says the option is
there to be used.  Either the program or the man page should be changed, so
that the program's behavior and the man page are in accord.
Comment 1 Conrad Meyer freebsd_committer 2020-06-30 15:42:09 UTC
Note: Both 10.3 and 11.1 are well past EOL.

We need more information to reproduce: what -p option was being used, and what was the error message?  It works on CURRENT:

$ sudo mdmfs -p 700 tmpfs ./test-mount
$ echo $?
0
$ mount
...
tmpfs on /usr/home/conrad/test-mount (tmpfs, local)
$ ls -lhd ./test-mount/
drwx------ 2 conrad conrad 0 Jun 30 08:40 ./test-mount//
Comment 2 Scott Bennett 2020-07-02 05:04:09 UTC
I was unable to get it to work under 11.1, 11.2, and (I am not quite certain) in
11.3.  I had waited to file this PR for a long time and, when I discovered a
few days ago that I could file simple (i.e., no attachments or any other kind
of uploads) PRs with lynx(1), I just filed it.  However, I had not tried it again with what
I am currently running, which is 
FreeBSD hellas 11.4-PRERELEASE FreeBSD 11.4-PRERELEASE #24 r360432: Tue Apr 28 18:48:15 CDT 2020     bennett@hellas:/usr/obj/usr/src/sys/hellas  amd64 .
I have now done so and discovered that you are now correct:  it should work
just fine with 11.4.
I apologize for the noise and am closing the PR as 'fixed'.