Bug 247697 - devel/p5-Perl-Critic broken with lang/perl5.32
Summary: devel/p5-Perl-Critic broken with lang/perl5.32
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Mathieu Arnold
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-01 19:37 UTC by Mike Andrews
Modified: 2020-07-01 19:37 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (mat)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Andrews 2020-07-01 19:37:31 UTC
Perl::Critic (which is a bit out of date) doesn't work with Perl 5.32 due to a missing dependency -- which in turn is likely due to a module being removed from the core Perl distribution in 5.32:

Can't locate Pod/PlainText.pm in @INC (you may need to install the Pod::PlainText module) (@INC contains: /usr/local/lib/perl5/site_perl/mach/5.32 /usr/local/lib/perl5/site_perl /usr/local/lib/perl5/5.32/mach /usr/local/lib/perl5/5.32) at /usr/local/lib/perl5/site_perl/Perl/Critic/Utils/POD.pm line 10.

There is no port for p5-Pod-PlainText.

This is likely an issue for upstream since Pod::PlainText is deprecated.