Bug 247750 - multimedia/get_iplayer: Update to 3.26
Summary: multimedia/get_iplayer: Update to 3.26
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Li-Wen Hsu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-03 23:13 UTC by Jamie Landeg-Jones
Modified: 2020-07-04 08:40 UTC (History)
1 user (show)

See Also:


Attachments
cd /usr/ports/multimedia/get_iplayer && patch < <patch-filename> (4.37 KB, patch)
2020-07-03 23:13 UTC, Jamie Landeg-Jones
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jamie Landeg-Jones 2020-07-03 23:13:17 UTC
Created attachment 216184 [details]
cd /usr/ports/multimedia/get_iplayer && patch < <patch-filename>

This patch updates get_iplayer to version 3.26.

There are also fixes to the rc script for get_player.cgi, which hasn't been working for a while.

General changes:

- Updated to 3.26

- AtomicParsley and ffmpeg options are now enabled by default. - this helps pkg users - get_iplayer is virtually useless without ffmpeg.

cgi/rc script changes:

- "get_iplayer_logfile" added. If set, logs activity to the corresponding
  file.

- "get_iplayer_chdir" now works as intended. If unset, it now defaults
  to the get_iplayer home directory rather than "/", for those who'd
  prefer to set it that way.

- "get_iplayer_flags" should now work correctly.

- Running process fixed - it was looking for /usr/bin/perl which should
  have been changed to /usr/local/bin/perl some time ago.

Thanks to lundincahill@gmail.com for pointing out the issues with the rc script.
Comment 1 commit-hook freebsd_committer 2020-07-04 08:40:53 UTC
A commit references this bug:

Author: lwhsu
Date: Sat Jul  4 08:40:28 UTC 2020
New revision: 541176
URL: https://svnweb.freebsd.org/changeset/ports/541176

Log:
  Update to 3.26

  PR:		247750
  Submitted by:	Jamie Landeg-Jones <jamie@catflap.org> (maintainer)

Changes:
  head/multimedia/get_iplayer/Makefile
  head/multimedia/get_iplayer/distinfo
  head/multimedia/get_iplayer/files/get_iplayer.in
  head/multimedia/get_iplayer/pkg-message