Bug 247805 - math/maxima: Fails to build: src/binary-ecl/maxima.fas: No such file or directory (poudriere on amd64 12.1 stable)
Summary: math/maxima: Fails to build: src/binary-ecl/maxima.fas: No such file or direc...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: Niclas Zeising
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2020-07-06 14:17 UTC by Robert Cina
Modified: 2020-07-07 15:54 UTC (History)
4 users (show)

See Also:
koobs: merge-quarterly?


Attachments
Patch that adds devel/libatomic as build dependency for maxima port (338 bytes, patch)
2020-07-07 02:51 UTC, Robert Cina
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Cina 2020-07-06 14:17:53 UTC
The port math/maxima fails to build for me using poudriere on amd64 12.1 stable.

The error from the build log is shown below:

-exec /bin/sh -c '\''cd '\''$2'\'' && chmod 755 "$@"'\'' . {} +  -o -type f -exec /bin/sh -c '\''cd '\''$2'\'' && chmod 0644 "$@"'\'' . {} + \)' COPYTREE_SHARE . /wrkdirs/usr/ports/math/maxima/work/stage/usr/local/share/examples/maxima '-name *\.dem'
install  -m 444 /wrkdirs/usr/ports/math/maxima/work/maxima-5.44.0/doc/man/maxima.1.gz /wrkdirs/usr/ports/math/maxima/work/stage/usr/local/man/man1
/bin/mkdir -p /wrkdirs/usr/ports/math/maxima/work/stage/usr/local/lib/ecl
install  -m 0644 /wrkdirs/usr/ports/math/maxima/work/maxima-5.44.0/src/binary-ecl/maxima.fas  /wrkdirs/usr/ports/math/maxima/work/stage/usr/local/lib/ecl
install: /wrkdirs/usr/ports/math/maxima/work/maxima-5.44.0/src/binary-ecl/maxima.fas: No such file or directory
*** Error code 71

Stop.
make: stopped in /usr/ports/math/maxima
=>> Cleaning up wrkdir
===>  Cleaning for maxima-5.44.0_1
build of math/maxima | maxima-5.44.0_1 ended at Sun Jul  5 17:38:17 EDT 2020
build time: 00:02:11
!!! build failure encountered !!!
Comment 1 Li-Wen Hsu freebsd_committer 2020-07-06 17:03:13 UTC
There is no maintainer of this port right now. May I suggest you to create a patch to fix this, or asking help on the related mailing lists?
Comment 2 Robert Cina 2020-07-06 17:54:49 UTC
Sure I'm willing to help create a patch to fix this but not sure where to start to debug the error.   I guess I will ask for help on the ports mailing list and go from there. 

Thanks.
Comment 3 Robert Cina 2020-07-07 02:51:39 UTC
Created attachment 216273 [details]
Patch that adds devel/libatomic as build dependency for maxima port

I found the reason for the maxima port failing to build using poudriere on 12.1 Stable for me.  There was a missing header atomic_ops.h that was causing the build to fail.  After adding a build dependency for devel/libatomic_ops port the maxima now builds correctly for me.  

Hopefully this helps others.
Comment 4 marc.priggemeyer 2020-07-07 08:43:01 UTC
Thanks for the patch! I can confirm that it works.
Comment 5 commit-hook freebsd_committer 2020-07-07 15:18:09 UTC
A commit references this bug:

Author: zeising
Date: Tue Jul  7 15:17:23 UTC 2020
New revision: 541427
URL: https://svnweb.freebsd.org/changeset/ports/541427

Log:
  math/maxima: Fix build with SAGE option

  Fix the build of math/maxima with the SAGE option [1]
  Add missing man pages to plist

  PR:		247805 [1]
  Submitted by:	Robert Cina (with modifications) [1]

Changes:
  head/math/maxima/Makefile
  head/math/maxima/pkg-plist
Comment 6 Niclas Zeising freebsd_committer 2020-07-07 15:34:50 UTC
This should have been fixed now.  Thank you for the report, and apologies for the breakage.
I don't believe this needs to be merged to the quarterly branch.  math/maxima was updated after the branch was created.
If there still are issues, please let me know!
Comment 7 Fernando Apesteguía freebsd_committer 2020-07-07 15:54:59 UTC
^Triage: Assign to committer who resolved the issue.