Bug 247831 - editors/libreoffice fails at patch phase (ports @541443)
Summary: editors/libreoffice fails at patch phase (ports @541443)
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-office (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-07 19:24 UTC by tech-lists
Modified: 2020-07-07 23:44 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (office)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tech-lists 2020-07-07 19:24:55 UTC
Hi,

ports @541443
12-stable r361108 host
12-stable r359155 jail

editors/libreoffice options:

[00:00:01] ---Begin OPTIONS List---
[00:00:01] ===> The following configuration options are available for libreoffice-6.4.5:
[00:00:01]      CUPS=on: CUPS printing system support
[00:00:01]      DOCS=off: Build and/or install documentation
[00:00:01]      GNOME=off: GNOME desktop environment support
[00:00:01]      GTK3=off: GTK+ 3 GUI toolkit support (broken visual style)
[00:00:01]      JAVA=on: Add Java support (XML filters, macros, DB connections)
[00:00:01]      KF5=on: KF5/Qt5 GUI toolkit support (implies QT5)
[00:00:01]      MMEDIA=on: Enable multimedia backend for Impress
[00:00:01]      PGSQL=off: Build with PostgreSQL-SDBC driver
[00:00:01]      QT5=on: Qt5 GUI toolkit support (default visual style)
[00:00:01]      SDK=off: Build with SDK
[00:00:01]      TEST=off: Run all regression tests
[00:00:01]      WEBDAV=on: Enable WebDAV protocol
[00:00:01] ===> Use 'make config' to modify these settings

poudriere build of editors/libreoffice fails here:

[00:01:47] =======================<phase: patch          >============================
[00:01:48] ===>  Patching for libreoffice-6.4.5
[00:01:49] ===>  Applying FreeBSD patches for libreoffice-6.4.5 from /usr/ports/editors/libreoffice/files
[00:01:49] Ignoring previously applied (or reversed) patch.
[00:01:49] 1 out of 1 hunks ignored--saving rejects to vcl/qt5/Qt5Instance.cxx.rej
[00:01:49] ===>  FAILED Applying FreeBSD patch-vcl_qt5_Qt5Instance.cxx (nonexistent)
[00:01:49] ===> Cleanly applied FreeBSD patch(es)  patch-Makefile.in patch-aarch64-gcc3_linux_aarch64 patch-bin_distro-install-desktop-integration patch-bridges_source_cpp__uno_gcc3__linux__aarch64_cpp2uno.cxx patch-bridges_source_cpp__uno_gcc3__linux__intel_except.cxx patch-configure patch-configure.aarch64 patch-cxa_exception patch-desktop_unx_source_pagein.c patch-include_LibreOfficeKit_LibreOfficeKitInit.h patch-officecfg_registry_schema_org_openoffice_Office_Common.xcs patch-powerpc patch-python382 patch-sal_osl_unx_system.hxx patch-sal_osl_unx_thread.cxx patch-sal_osl_unx_uunxapi.cxx patch-shell_source_unix_exec_shellexec.cxx patch-solenv_gbuild_UnpackedTarball.mk patch-solenv_gbuild_platform_FREEBSD__AARCH64__GCC.mk patch-solenv_gbuild_platform_unxgcc.mk patch-svtools_source_svrtf_parrtf.cxx patch-sysui_desktop_share_create_tree.sh patch-ucb_source_ucp_webdav_DateTimeHelper.cxx patch-vcl_Executable__visualbackendtest.mk patch-vcl_qt5_Qt5Frame.cxx patch-vcl_qt5_Qt5Instance.cxx
[00:01:49] ===> FAILED to apply cleanly FreeBSD patch(es)  patch-vcl_qt5_Qt5Instance.cxx (nonexistent)
[00:01:49] *** Error code 1
[00:01:49] 
[00:01:49] Stop.
[00:01:49] make: stopped in /usr/ports/editors/libreoffice
[00:28:44] =>> Cleaning up wrkdir
[00:28:45] ===>  Cleaning for libreoffice-6.4.5
[00:28:52] build of editors/libreoffice | libreoffice-6.4.5 ended at Tue Jul  7 19:18:28 BST 2020
[00:28:52] build time: 00:28:52
[00:28:52] !!! build failure encountered !!!
Comment 1 Li-Wen Hsu freebsd_committer 2020-07-07 19:53:24 UTC
I'm unable to reproduce this, could you check again that you have the latest patch-vcl_qt5_Qt5Instance.cxx?
Comment 2 tech-lists 2020-07-07 20:32:37 UTC
(In reply to Li-Wen Hsu from comment #1)

previous run was at r541443. I'm trying again at r541451.

How would I check for the latest patch? I thought it had been pushed to the ports tree already?
Comment 3 Li-Wen Hsu freebsd_committer 2020-07-07 20:40:48 UTC
(In reply to tech-lists from comment #2)

I think the fastest way is checking

https://www.freshports.org/editors/libreoffice/
or
https://svnweb.freebsd.org/ports/head/editors/libreoffice/

Last update of editores/libreoffice is ports r541383 so I guess there might be something wrong during in the checkout/update. Can you try to remove that directory and do `svn up` again? You can even compare the content with the svnweb.
Comment 4 tech-lists 2020-07-07 21:44:45 UTC
(In reply to Li-Wen Hsu from comment #3)

ok to be on the safe side i've deleted the ports tree and will try again with a fresh one
Comment 5 tech-lists 2020-07-07 23:42:58 UTC
Hi,

I noticed there was a dir at the top of the portstree called libreoffice.patches. I didn't know if there was any other files concerning libreoffice in the top level dotfiles which is why the ports tree got deleted then new one fetched, then built from that.

All seems to be good, it built without error, thanks for your help and sorry for the noise.