Bug 247852 - procstat(1) is missing many command line arguments
Summary: procstat(1) is missing many command line arguments
Status: Closed Unable to Reproduce
Alias: None
Product: Documentation
Classification: Unclassified
Component: Manual Pages (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-08 17:00 UTC by Yuri Victorovich
Modified: 2020-07-11 14:37 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2020-07-08 17:00:23 UTC
The list of all supported arguments: "abCcefHhijkLlM:N:nrSstvw:x"

The list of arguments described in the manpage:
```
     procstat [-h] [-n] [-w interval]
              [-b | -c | -f | -i | -j | -k | -s | -t | -v] [-a | pid ...]
```

M, N, n and several other arguments are missing.

12.1 r359625
Comment 1 Allan Jude freebsd_committer 2020-07-11 14:24:18 UTC
On 12.1, the procstat man page looks like this:

SYNOPSIS
     procstat [--libxo] [-h] [-M core] [-N system] [-w interval] command
              [pid ... | core ...]
     procstat [--libxo] -a [-h] [-M core] [-N system] [-w interval] command
     procstat [--libxo] [-h] [-M core] [-N system] [-w interval] [-b | -c |
              -e | -f [-C] | -i [-n] | -j [-n] | -k [-k] | -l | -r [-H] | -s |
              -S | -t | -v | -x] [pid ... | core ...]
     procstat [--libxo] -a [-h] [-M core] [-N system] [-w interval] [-b | -c |
              -e | -f [-C] | -i [-n] | -j [-n] | -k [-k] | -l | -r [-H] | -s |
              -S | -t | -v | -x]
     procstat [--libxo] -L [-h] [-M core] [-N system] [-w interval] core ...


It does not appear to be missing the M, N, or n flags
Comment 2 PauAmma 2020-07-11 14:37:17 UTC
-n is explained in DESCRIPTION, and -M sort-of is. -N, as far as I can tell, isn't, and probably should be. Its argument seems to be something to extract a nlistf (namelist?) from.

In -current (head/usr.bin/procstat/procstat.1 344823 2019-03-05 19:45:37Z markj), the manual page SYNOPSIS at least looks similar to me.

What other flags do you think are missing from the SYNOPSIS or DESCRIPTION?