Bug 247935 - devel/meson: update to 0.55.3
Summary: devel/meson: update to 0.55.3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jan Beich
URL: https://mesonbuild.com/Release-notes-...
Keywords: needs-qa, patch
: 248487 249246 (view as bug list)
Depends on: 246485
Blocks:
  Show dependency treegraph
 
Reported: 2020-07-12 17:11 UTC by Jan Beich
Modified: 2020-09-14 18:38 UTC (History)
6 users (show)

See Also:
tcberner: maintainer-feedback+
antoine: exp-run+


Attachments
v1 (0.55.0) (1.66 KB, patch)
2020-07-12 17:11 UTC, Jan Beich
no flags Details | Diff
v2 (0.55.1) (1.68 KB, patch)
2020-08-17 11:14 UTC, Jan Beich
no flags Details | Diff
v3 (0.55.2) (1.70 KB, patch)
2020-09-11 04:42 UTC, Jan Beich
no flags Details | Diff
v3.1 (0.55.2) (1.83 KB, patch)
2020-09-11 10:30 UTC, Jan Beich
no flags Details | Diff
v4 (0.55.3) (1.83 KB, patch)
2020-09-11 18:02 UTC, Jan Beich
tcberner: maintainer-approval+
Details | Diff
v4.1 (0.55.3) (2.37 KB, patch)
2020-09-12 16:51 UTC, Jan Beich
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2020-07-12 17:11:43 UTC
Created attachment 216405 [details]
v1 (0.55.0)
Comment 3 Jan Beich freebsd_committer 2020-08-05 20:06:41 UTC
*** Bug 248487 has been marked as a duplicate of this bug. ***
Comment 4 Yuri Victorovich freebsd_committer 2020-08-05 20:37:49 UTC
audio/gradio failure "ERROR: Compiling Vala requires C. Add C to your project languages and rerun Meson." seems to be due to a regression in meson: https://github.com/mesonbuild/meson/issues/7550
Comment 5 Yuri Victorovich freebsd_committer 2020-08-05 20:46:47 UTC
Another relevant upstream issue: https://github.com/mesonbuild/meson/issues/7551
Comment 6 Jan Beich freebsd_committer 2020-08-17 11:14:19 UTC
Created attachment 217279 [details]
v2 (0.55.1)

Upstream fixed some regressions e.g., audio/gradio builds fine with meson 0.55.1. 

Can you redo exp-run?
Comment 9 Alex S 2020-08-20 21:49:08 UTC
(In reply to Antoine Brodin from comment #8)

> 113i386-default-PR244008
> PR244008

FYI, this naming scheme looks a bit confusing on pkg-status.freebsd.org.
Comment 10 John Hein 2020-08-21 02:02:19 UTC
Follow the issue upstream: https://github.com/mesonbuild/meson/issues/7551
Comment 11 Yuri Victorovich freebsd_committer 2020-08-27 23:30:29 UTC
The upstream claims that this PR fixes the rpath issue: https://github.com/mesonbuild/meson/pull/7629
Comment 12 daniel.engberg.lists 2020-09-03 22:10:41 UTC
https://github.com/mesonbuild/meson/issues/7515 might also be worth tracking
Comment 13 Jan Beich freebsd_committer 2020-09-11 04:42:13 UTC
Created attachment 217883 [details]
v3 (0.55.2)

Upstream fixed some regressions. Can you redo exp-run?
Comment 14 Tobias C. Berner freebsd_committer 2020-09-11 07:14:29 UTC
*** Bug 249246 has been marked as a duplicate of this bug. ***
Comment 15 Tobias C. Berner freebsd_committer 2020-09-11 07:16:46 UTC
@jbeich

I had a second shebang file in my pr

SHEBANG_FILES=	mesonbuild/rewriter.py \
		mesonbuild/scripts/cmake_run_ctgt.py


Mfg Tobias
Comment 16 Jan Beich freebsd_committer 2020-09-11 10:30:44 UTC
Created attachment 217887 [details]
v3.1 (0.55.2)

(In reply to Tobias C. Berner from comment #15)
> SHEBANG_FILES=	mesonbuild/rewriter.py \

Taking along for an exp-run is OK but "#!/usr/bin/env python3" there predates 0.55.0, so you could've just landed it independently.
Comment 17 Jan Beich freebsd_committer 2020-09-11 10:38:34 UTC
Nevermind, I forgot the patch here touches SHEBANG_FILES, so adding mesonbuild/rewriter.py would have required rebasing anyway.
Comment 20 Jan Beich freebsd_committer 2020-09-12 12:58:04 UTC
(In reply to Antoine Brodin from comment #19)
> ===>   Installing existing package /packages/All/meson-0.55.2.txz

Can you retry with meson 0.55.3? x11/gnome-shell builds fine on 12.1 amd64.
Comment 21 Antoine Brodin freebsd_committer 2020-09-12 13:19:27 UTC
(In reply to Jan Beich from comment #20)

Can you try on 11.3 ?
Comment 22 Jan Beich freebsd_committer 2020-09-12 16:51:25 UTC
Created attachment 217921 [details]
v4.1 (0.55.3)

(In reply to Antoine Brodin from comment #21)
> Can you try on 11.3 ?

Both 11.3 and 11.4 failed (see below). Given FreeBSD < 12 on Tier1 uses ancient BFD linker let's switch to LLD. USES=compiler:c11 kinda ensures either LLD or new BFD is available.

Installing src/libgnome-shell.so to /wrkdirs/usr/ports/x11/gnome-shell/work/stage/usr/local/lib/gnome-shell
Stripping target 'src/libgnome-shell.so' using strip.
New rpath must not be longer than the old one.
 Old: b'/usr/local/lib/mutter:/usr/local/lib/gnome-shell'
 New: b'/usr/local/lib/mutter:/usr/local/lib/gnome-shell:/usr/local/lib/gnome-shell'
FAILED: meson-install 
/usr/local/bin/meson install --no-rebuild
ninja: build stopped: subcommand failed.
*** Error code 1
Comment 23 Antoine Brodin freebsd_committer 2020-09-14 15:25:13 UTC
Exp-run looks fine
Comment 24 commit-hook freebsd_committer 2020-09-14 18:36:12 UTC
A commit references this bug:

Author: jbeich
Date: Mon Sep 14 18:35:39 UTC 2020
New revision: 548668
URL: https://svnweb.freebsd.org/changeset/ports/548668

Log:
  devel/meson: update to 0.55.3

  - Fix "/usr/bin/env python3" in one more file [1]

  Changes:	https://mesonbuild.com/Release-notes-for-0-55-0.html
  Changes:	https://github.com/mesonbuild/meson/compare/0.54.3...0.55.3
  Reported by:	GitHub (watch releases)
  PR:		247935
  With help of:	yuri
  Exp-run by:	antoine
  Submitted by:	tcberner [1]
  Approved by:	tcberner

Changes:
  head/devel/meson/Makefile
  head/devel/meson/distinfo
  head/x11/gnome-shell/Makefile