Bug 247940 - Introduce gssapi=.. in DEFAULT_VERSIONS like for ssl=...
Summary: Introduce gssapi=.. in DEFAULT_VERSIONS like for ssl=...
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Port Management Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-12 22:29 UTC by Michael Osipov
Modified: 2020-07-25 22:23 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Osipov 2020-07-12 22:29:14 UTC
There is Mk/Uses/gssapi.mk, yet Mk/bsd.default-versions.mk does not handle gssapi=none|base|mit|heimdal. This forces ports users for Uses=gssapi to configure every single port for MIT or something else instead of doing DEFAULT_VERSIONS+=gssapi=mit in make.conf. I consider gssapi=base is a sane default.
Comment 1 Li-Wen Hsu freebsd_committer 2020-07-20 15:05:13 UTC
CC Uses/gssapi.mk maintainer.