Bug 247961 - x11-fm/thunar: Fix runtime crash with DEBUG=ON
Summary: x11-fm/thunar: Fix runtime crash with DEBUG=ON
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-xfce (Nobody)
URL: https://gitlab.xfce.org/xfce/thunar/-...
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2020-07-14 04:58 UTC by rozhuk.im
Modified: 2020-07-18 10:28 UTC (History)
2 users (show)

See Also:
madpilot: maintainer-feedback+
madpilot: merge-quarterly+


Attachments
patch (1.01 KB, patch)
2020-07-14 04:58 UTC, rozhuk.im
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description rozhuk.im 2020-07-14 04:58:22 UTC
Created attachment 216427 [details]
patch
Comment 1 rozhuk.im 2020-07-14 05:23:03 UTC
IMHO thunar may crash without DEBUG, or at least all other code have no sense if "file" not valid.
Comment 2 Guido Falsi freebsd_committer 2020-07-15 13:40:22 UTC
Thanks, testing.
Comment 3 commit-hook freebsd_committer 2020-07-16 13:25:33 UTC
A commit references this bug:

Author: madpilot
Date: Thu Jul 16 13:25:16 UTC 2020
New revision: 542357
URL: https://svnweb.freebsd.org/changeset/ports/542357

Log:
  Import patch merged upstream to fix sporadic crashes caused by an
  incorrect assertion in the cose.

  PR:		247961
  Submitted by:	rozhuk.im@gmail.com
  MFH:		2020Q3

Changes:
  head/x11-fm/thunar/Makefile
  head/x11-fm/thunar/files/
  head/x11-fm/thunar/files/patch-thunar_thunar-list-model.c
Comment 4 Guido Falsi freebsd_committer 2020-07-16 13:26:14 UTC
Patch Committed. Thanks!
Comment 5 commit-hook freebsd_committer 2020-07-18 10:28:23 UTC
A commit references this bug:

Author: madpilot
Date: Sat Jul 18 10:27:49 UTC 2020
New revision: 542488
URL: https://svnweb.freebsd.org/changeset/ports/542488

Log:
  MFH: r542357

  Import patch merged upstream to fix sporadic crashes caused by an
  incorrect assertion in the cose.

  PR:		247961
  Submitted by:	rozhuk.im@gmail.com

  Approved by:	ports-secteam (joneum)

Changes:
_U  branches/2020Q3/
  branches/2020Q3/x11-fm/thunar/Makefile
  branches/2020Q3/x11-fm/thunar/files/