Bug 248003 (cmake-3.18.0) - [exp-run] Update cmake to 3.18.0
Summary: [exp-run] Update cmake to 3.18.0
Status: Closed FIXED
Alias: cmake-3.18.0
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias C. Berner
URL: https://github.com/freebsd/freebsd-po...
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-15 14:54 UTC by Tobias C. Berner
Modified: 2020-08-16 09:27 UTC (History)
2 users (show)

See Also:
antoine: exp-run+


Attachments
v1 (16.40 KB, patch)
2020-07-15 14:54 UTC, Tobias C. Berner
no flags Details | Diff
v2 (21.19 KB, patch)
2020-08-09 08:09 UTC, Tobias C. Berner
no flags Details | Diff
v3 (24.73 KB, patch)
2020-08-09 12:23 UTC, Tobias C. Berner
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias C. Berner freebsd_committer 2020-07-15 14:54:08 UTC
Created attachment 216471 [details]
v1

Moin moin 

kde@ would like to ask for an exp-run to upgrade cmake to 3.18.0.

The patch is attached, but can also be found here:
https://people.freebsd.org/~tcberner/patches/cmake-3.18.0.v1.diff


mfg Tobias
Comment 2 Adriaan de Groot freebsd_committer 2020-08-03 07:08:02 UTC
Still failing (on the cmake 3.18 staging branch):
 - devel/folly
 - cad/opensta
 - graphics/qgis
 - graphics/qgis-ltr

I think tcberner fixed the rest.
Comment 3 Adriaan de Groot freebsd_committer 2020-08-09 07:32:22 UTC
cad/opensta fixed in the Area51 branch in c9a05d5757e6
graphics/qgis and graphics/qgis-ltr fixed in the Area51 branch in 0c63f3462799

That just leaves folly.
Comment 4 Tobias C. Berner freebsd_committer 2020-08-09 07:53:21 UTC
(In reply to Adriaan de Groot from comment #3)
and also net-p2p/libtorrent-rasterbar:
https://people.freebsd.org/~tcberner/logs/libtorrent-rasterbar-1.2.8.log
Comment 5 Tobias C. Berner freebsd_committer 2020-08-09 08:09:31 UTC
Created attachment 217106 [details]
v2

Here's v2 of the patch, which should work:

https://people.freebsd.org/~tcberner/patches/cmake-3.18.0.v2.diff

- net-p2p/libtorrent-rasterbar is marked broken
- devel/folly is marked broken
- graphics/gqis* patched
- cad/opensta patched
- devel/kms-cmake-utils fixed


mfg Tobias
Comment 6 Tobias C. Berner freebsd_committer 2020-08-09 12:23:40 UTC
Created attachment 217110 [details]
v3

- v3 unbreaks folly and libtorrent-rasterbar again
Comment 7 Tobias C. Berner freebsd_committer 2020-08-09 12:24:07 UTC
(In reply to Tobias C. Berner from comment #6)

https://people.freebsd.org/~tcberner/patches/cmake-3.18.0.v3.diff
Comment 9 Adriaan de Groot freebsd_committer 2020-08-13 08:29:45 UTC
Whoops, forgot about easyrpg-player in the process (I think from comment #2 I just suppressed thinking about it). The build (configure) failure is reproducible on 12-STABLE, so I'll chase it there.
Comment 10 commit-hook freebsd_committer 2020-08-13 10:06:33 UTC
A commit references this bug:

Author: adridg
Date: Thu Aug 13 10:05:50 UTC 2020
New revision: 544796
URL: https://svnweb.freebsd.org/changeset/ports/544796

Log:
  Fix games/easyrpg-player in advance of CMake 3.18 landing

  - This (still) builds with CMake 3.17
  - Circular dependency between harfbuzz and freetype causes
    build (configure) failures with CMake 3.18, although I don't
    see why CMake 3.17 doesn't fall over (it might be due to
    recent CMake module additions)
  - Reported upstream with alternate fix at
  	https://github.com/EasyRPG/Player/pull/2274

  PR:		248003

Changes:
  head/games/easyrpg-player/Makefile
  head/games/easyrpg-player/files/
  head/games/easyrpg-player/files/patch-builds_cmake_Modules_FindHarfbuzz.cmake
Comment 12 commit-hook freebsd_committer 2020-08-14 17:04:21 UTC
A commit references this bug:

Author: tcberner
Date: Fri Aug 14 17:03:30 UTC 2020
New revision: 544890
URL: https://svnweb.freebsd.org/changeset/ports/544890

Log:
  comms/wsjtx: prepare for cmake-3.18.x

  - this belongs into the "let's forget this ever happened category".
  - with cmake-3.18 the target to patch the thirdparty sources gets
    ran twice. Onde during build and once during the install phase.
  - we silently remove the patches again after the build is done, so
    that during the install phase, the patching is a no-op.

  PR:		248003

Changes:
  head/comms/wsjtx/Makefile
Comment 13 Tobias C. Berner freebsd_committer 2020-08-14 17:04:45 UTC
(In reply to Antoine Brodin from comment #11)
As adridg@ pointed out on IRC, darktable seems to be fixed by the update of the port to _3.
Comment 14 commit-hook freebsd_committer 2020-08-14 17:52:31 UTC
A commit references this bug:

Author: tcberner
Date: Fri Aug 14 17:51:44 UTC 2020
New revision: 544893
URL: https://svnweb.freebsd.org/changeset/ports/544893

Log:
  games/springlobby: prepare for cmake-3.18.1

  - remove unsupported 'libcurl' component from find(CURL) call

  PR:		248003

Changes:
  head/games/springlobby/files/patch-src_CMakeLists.txt
Comment 15 Tobias C. Berner freebsd_committer 2020-08-14 18:09:08 UTC
Moin moin 

This should be ready for hopefully the last run :)


mfg Tobias
Comment 17 Tobias C. Berner freebsd_committer 2020-08-16 08:34:55 UTC
(In reply to Antoine Brodin from comment #16)
Moin moin

The failure of deskutils/zanshin is unrelated to cmake; it fails the same way in svn (likely due to the update to release-service 20.08.0 last week).


mfg Tobias
Comment 18 Antoine Brodin freebsd_committer 2020-08-16 08:43:00 UTC
Exp-run looks fine in this case.
Comment 19 commit-hook freebsd_committer 2020-08-16 09:27:25 UTC
A commit references this bug:

Author: tcberner
Date: Sun Aug 16 09:27:22 UTC 2020
New revision: 545091
URL: https://svnweb.freebsd.org/changeset/ports/545091

Log:
  devel/cmake: update to 3.18.1

  - update to 3.18.1
  - new port devel/cmakedoc

  Thanks to adridg@ for tackling most of the fallout.

  PR:		248003
  Exp-run by:	antoine

Changes:
  head/cad/opensta/Makefile
  head/cad/opensta/files/patch-CMakeLists.txt
  head/devel/Makefile
  head/devel/cmake/Makefile
  head/devel/cmake/distinfo
  head/devel/cmake/pkg-plist
  head/devel/cmake-doc/Makefile
  head/devel/cmake-gui/Makefile
  head/devel/cmakedoc/
  head/devel/cmakedoc/Makefile
  head/devel/cmakedoc/distinfo
  head/devel/cmakedoc/pkg-descr
  head/devel/folly/files/patch-CMakeLists.txt
  head/devel/folly/files/patch-folly_experimental_symbolizer_Dwarf.cpp
  head/devel/folly/files/patch-folly_memory_detail_MallocImpl.h
  head/devel/kms-cmake-utils/Makefile
  head/graphics/qgis/files/patch-src_core_CMakeLists.txt
  head/graphics/qgis-ltr/files/patch-src_core_CMakeLists.txt
  head/net-p2p/libtorrent-rasterbar/Makefile
  head/net-p2p/libtorrent-rasterbar/files/
  head/net-p2p/libtorrent-rasterbar/files/patch-cmake_Modules_GeneratePkgConfig.cmake
Comment 20 Tobias C. Berner freebsd_committer 2020-08-16 09:27:52 UTC
Committed. Thanks for the exp-run.