Bug 248007 - sysutils/nss_ndb fails to install , pkg-static: Unable to access file /usr/ports/sysutils/nss_ndb/work/stage/usr/local/etc/nss_ndb.conf:No such file or directory
Summary: sysutils/nss_ndb fails to install , pkg-static: Unable to access file /usr/po...
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-16 00:02 UTC by Ulas SAYGIN
Modified: 2020-07-18 11:39 UTC (History)
2 users (show)

See Also:
pen: maintainer-feedback+


Attachments
Patch against r541425 (818 bytes, patch)
2020-07-17 13:32 UTC, James French
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ulas SAYGIN 2020-07-16 00:02:54 UTC
on Freebsd 12.1 , i tried to install by selecting only CFG option.
but it failed to install and give error.

i also tested other options, these also give same error.

you may also look this url to get more info.

https://github.com/ptrrkssn/nss_ndb/issues/4


usr/local/share/examples/nss_ndb
====> Compressing man pages (compress-man)
===> Installing for nss_ndb-1.0.23
===> Checking if nss_ndb is already installed
===> Registering installation for nss_ndb-1.0.23
pkg-static: Unable to access file /usr/ports/sysutils/nss_ndb/work/stage/usr/loc al/etc/nss_ndb.conf:No such file or directory
*** Error code 74

Stop.
make[1]: stopped in /usr/ports/sysutils/nss_ndb
*** Error code 1

Stop.
make: stopped in /usr/ports/sysutils/nss_ndb
Comment 1 James French 2020-07-17 13:32:10 UTC
Created attachment 216514 [details]
Patch against r541425

The attached patch should address this issue
Comment 2 Peter Eriksson 2020-07-18 11:39:34 UTC
The patch is looking good as far as I can tell.

- Peter