Bug 248058 - net-mgmt/net-snmp: Install newsyslog config as a sample
Summary: net-mgmt/net-snmp: Install newsyslog config as a sample
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Ryan Steinmetz
URL:
Keywords: buildisok, easy, feature
: 248466 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-07-18 03:32 UTC by James French
Modified: 2020-09-12 12:58 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (zi)
koobs: merge-quarterly?


Attachments
Patch to install newsyslog.conf.d/net-snmp.conf as a @sample (1.01 KB, patch)
2020-07-18 03:32 UTC, James French
no flags Details | Diff
Poudriere build log (818.67 KB, text/plain)
2020-07-18 03:35 UTC, James French
no flags Details
Patch to install newsyslog.conf.d/net-snmp.conf as a @sample (1.54 KB, patch)
2020-07-18 05:16 UTC, James French
no flags Details | Diff
Poudriere build log (818.67 KB, text/plain)
2020-07-18 05:23 UTC, James French
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description James French 2020-07-18 03:32:26 UTC
Created attachment 216527 [details]
Patch to install newsyslog.conf.d/net-snmp.conf as a @sample

net-mgmt/net-snmp ships with a sample newsyslog.conf file that gets installed into /usr/local/etc/newsyslog.conf.d.

If a user decides to make changes to this file then those changes:
- Get overwritten when the package is updated
- Get complained about by periodic-security because the installed file no longer matches the package checksum

This patch instead installs the sample file under ${EXAMPLESDIR}/newsyslog.conf and uses @sample to install it under etc/newsyslog.conf.d.
Comment 1 James French 2020-07-18 03:35:13 UTC
Created attachment 216528 [details]
Poudriere build log
Comment 2 James French 2020-07-18 04:04:28 UTC
The attached patch only works if newsyslog.conf.d already exists. Putting together a correction now.
Comment 3 James French 2020-07-18 05:16:17 UTC
Created attachment 216530 [details]
Patch to install newsyslog.conf.d/net-snmp.conf as a @sample

Changes:
- Installs the newsyslog file under share/snmp/newsyslog.conf.sample
- Installation has been moved to the install-config rather than post-install
Comment 4 James French 2020-07-18 05:23:56 UTC
Created attachment 216531 [details]
Poudriere build log
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2020-07-18 07:29:22 UTC
^Triage: [tags] in issue Titles are deprecated
Comment 6 Automation User 2020-08-02 00:13:19 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/173342776
Comment 7 Dries Michiels 2020-08-09 07:43:46 UTC
*** Bug 248466 has been marked as a duplicate of this bug. ***
Comment 8 James French 2020-09-04 07:06:20 UTC
Any chance we could get this committed under maintainer-timeout please? With bug 248466 as evidence there's a few people running into this issue.
Comment 9 Ryan Steinmetz freebsd_committer freebsd_triage 2020-09-04 16:19:21 UTC
This will be included in the update to 5.9
Comment 10 James French 2020-09-04 16:34:59 UTC
(In reply to Ryan Steinmetz from comment #9)

Perfect, thanks for the feedback!
Comment 11 Ryan Steinmetz freebsd_committer freebsd_triage 2020-09-12 12:58:26 UTC
Committed as part of the 5.9 update