Bug 248089 - biology/htslib: Update to 1.10.2, Add patch for libcurl API change
Summary: biology/htslib: Update to 1.10.2, Add patch for libcurl API change
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jason W. Bacon
URL: https://github.com/samtools/samtools/...
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2020-07-19 01:57 UTC by Jason W. Bacon
Modified: 2020-08-03 18:23 UTC (History)
2 users (show)

See Also:
cartwright: maintainer-feedback+
koobs: merge-quarterly?


Attachments
Unified diff (9.95 KB, patch)
2020-07-19 01:57 UTC, Jason W. Bacon
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jason W. Bacon freebsd_committer 2020-07-19 01:57:03 UTC
Created attachment 216561 [details]
Unified diff

Upgrade to latest release + a fix for automatic reference downloads failing due to a libcurl API change:

https://github.com/samtools/samtools/issues/1254#issuecomment-656164294

Note that biology/htslib and biology/samtools should be upgraded at the same time to maintain API compatibility.  Another PR for samtools will follow shortly.
Comment 1 Jason W. Bacon freebsd_committer 2020-07-19 14:42:50 UTC
Updated work-in-progress htslib, samtools, and bcftools ports are here:

https://github.com/outpaddling/freebsd-ports-wip

I confirmed that biology/cufflinks builds against the new htslib.

The remaining htslib dependents are my own ports.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2020-07-20 02:06:23 UTC
^Triage: Correct Component, request feedback from maintainer
Comment 3 cartwright 2020-07-21 21:45:46 UTC
Looks good to me.
Comment 4 cartwright 2020-07-21 21:49:37 UTC
It seems like Jason maintains a lot of biology ports for FreeBSD and I am fine with him taking over as maintainer of my biology ports if he wants.
Comment 5 Jason W. Bacon freebsd_committer 2020-07-24 15:05:57 UTC
I can maintain htslib, samtools, and bcftools for the time being.

Thanks for your work on them and don't hesitate to keep contributing updates.

   JB
Comment 6 commit-hook freebsd_committer 2020-08-03 17:40:48 UTC
A commit references this bug:

Author: jwb
Date: Mon Aug  3 17:40:07 UTC 2020
New revision: 544090
URL: https://svnweb.freebsd.org/changeset/ports/544090

Log:
  biology/htslib: Upgrade to 1.10.2

  Numerous bug fixes and enhancements since 1.9:
  https://github.com/samtools/htslib/tags

  Bump PORTREVISION on dependents that don't require additional patching

  PR:             248089

Changes:
  head/biology/bcftools/Makefile
  head/biology/cufflinks/Makefile
  head/biology/htslib/Makefile
  head/biology/htslib/distinfo
  head/biology/htslib/files/patch-Makefile
  head/biology/htslib/files/patch-hfile__libcurl.c
  head/biology/htslib/pkg-plist
  head/biology/jellyfish/Makefile
  head/biology/pbbam/Makefile
  head/biology/samtools/Makefile
  head/biology/tabixpp/Makefile
  head/biology/vcflib/Makefile
Comment 7 Jason W. Bacon freebsd_committer 2020-08-03 17:47:44 UTC
Committed with additional clean-up.
Comment 8 commit-hook freebsd_committer 2020-08-03 18:16:57 UTC
A commit references this bug:

Author: jwb
Date: Mon Aug  3 18:16:55 UTC 2020
New revision: 544096
URL: https://svnweb.freebsd.org/changeset/ports/544096

Log:
  biology/bcftools: Upgrade to 1.10.2

  Numerous bug fixes and enhancements since 1.9:
  https://github.com/samtools/bcftools/tags

  Take maintainership per ports/248089.

  PR:             ports/248089

Changes:
  head/biology/bcftools/Makefile
  head/biology/bcftools/distinfo
  head/biology/bcftools/files/patch-Makefile
  head/biology/bcftools/files/patch-prob1.c
  head/biology/bcftools/files/patch-test_test.pl
  head/biology/bcftools/pkg-plist
Comment 9 commit-hook freebsd_committer 2020-08-03 18:23:03 UTC
A commit references this bug:

Author: jwb
Date: Mon Aug  3 18:22:07 UTC 2020
New revision: 544098
URL: https://svnweb.freebsd.org/changeset/ports/544098

Log:
  biology/samtools: Upgrade to 1.10

  Numerous bug fixes and enhancements:
  https://github.com/samtools/samtools/releases/tag/1.10

  Take maintainership per ports/248089

  PR:             ports/248089

Changes:
  head/biology/samtools/Makefile
  head/biology/samtools/distinfo
  head/biology/samtools/files/patch-Makefile
  head/biology/samtools/files/patch-test_test.pl
  head/biology/samtools/pkg-plist