Bug 248284 - ppp does not work with the _fix suffix in rc.conf when using profiles
Summary: ppp does not work with the _fix suffix in rc.conf when using profiles
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: conf (show other bugs)
Version: 12.1-RELEASE
Hardware: Any Any
: --- Affects Some People
Assignee: Eugene Grosbein
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-26 22:29 UTC by Paul Webster
Modified: 2020-07-28 09:38 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Webster 2020-07-26 22:29:50 UTC
# TOTALLY IGNORES _fib, the rest is fine

# PPP Config
ppp_enable="YES"
ppp_profile="bt1 bt2"
## BT1
ppp_bt1_mode="ddial"
ppp_bt1_unit=1
ppp_bt1_fib=1
ppp_bt1_nice="-20"
## BT2
ppp_bt2_mode="ddial"
ppp_bt2_unit=2
ppp_bt2_fib=2
ppp_bt2_nice="-20" sda


totally ignores _fib
Comment 1 Andriy Gapon freebsd_committer 2020-07-27 08:42:39 UTC
Just curious, why do you think that fib and nice should do anything?
Comment 2 Eugene Grosbein freebsd_committer 2020-07-28 02:18:50 UTC
Please read rc.conf(5) manual page carefully for syntax description. There are no such settings as ppp_<profile>_fib or ppp_<profile>_nice.

Also, please use FreeBSD web forums or mailing lists first for such discussions and leave Bugzilla for bug reporting.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2020-07-28 09:04:47 UTC
Could we improve rc more generally to display unused/invalid variables when specified by the user, improving UX, mistake proofing (Poka-yoke [1]) and reducing support overhead?

[1] https://en.wikipedia.org/wiki/Poka-yoke
Comment 4 Eugene Grosbein freebsd_committer 2020-07-28 09:19:46 UTC
(In reply to Kubilay Kocak from comment #3)

I doubt it because rc.conf is just shell-script assigning variables that can be used in numerous local scripts including those installed by ports of developed locally.

It may also contain local settings used by local scripts started by cron and even devd.
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2020-07-28 09:38:00 UTC
Thanks Eugene

@Reporter If there is a concrete proposal/improvement that can be made associated with this issue, please don't hesitate to re-open with additional details.

^Triage: Assign to committer that (originally resolved), cc me.