Bug 248322 - sysutils/e2fsprogs fails to build (testing phase)
Summary: sysutils/e2fsprogs fails to build (testing phase)
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Matthias Andree
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-28 10:54 UTC by gja822
Modified: 2020-07-30 16:41 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (mandree)


Attachments
build log for sysutils/e2fsprogs (202.28 KB, text/plain)
2020-07-28 10:54 UTC, gja822
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description gja822 2020-07-28 10:54:35 UTC
Created attachment 216833 [details]
build log for sysutils/e2fsprogs

Trying to compile sysutils/e2fsprogs end with an error for me.
FreeBSD 12.1-STABLE r363140 amd64

     313 tests succeeded	       5 tests failed
Tests failed: f_detect_xfs f_ext_journal j_corrupt_ext_jnl_sb_csum j_ext_long_revoke_trans j_ext_long_trans 
gmake[2]: *** [Makefile:395: test_post] Error 1
gmake[2]: Leaving directory '/usr/ports/sysutils/e2fsprogs/work/e2fsprogs-1.45.6/tests'
==> /usr/ports/sysutils/e2fsprogs/work/e2fsprogs-1.45.6/tests/f_detect_xfs.failed <==
--- f_detect_xfs/expect	2020-03-21 04:24:04.000000000 +0000
+++ f_detect_xfs.log	2020-07-28 10:48:08.570452000 +0000
@@ -11,7 +11,6 @@
  or
     e2fsck -b 32768 <device>
 
-test.img contains a xfs file system labelled 'test_filsys'
 *** debugfs
 debugfs: Bad magic number in super-block while trying to open test.img
 test.img contains a xfs file system labelled 'test_filsys'

==> /usr/ports/sysutils/e2fsprogs/work/e2fsprogs-1.45.6/tests/f_ext_journal.failed <==
--- f_ext_journal/expect.1	2020-03-21 04:24:04.000000000 +0000
+++ f_ext_journal.1.log	2020-07-28 10:48:11.627948000 +0000
@@ -1,8 +1,3 @@
 test_filesys: recovering journal
-Pass 1: Checking inodes, blocks, and sizes
-Pass 2: Checking directory structure
-Pass 3: Checking directory connectivity
-Pass 4: Checking reference counts
-Pass 5: Checking group summary information
-test_filesys: 89/2560 files (0.0% non-contiguous), 170/2560 blocks
-Exit status is 0
+Signal (11) SIGSEGV si_code=SEGV_MAPERR fault addr=0x1000
+Exit status is 8
--- f_ext_journal/expect.2	2020-03-21 04:24:04.000000000 +0000
+++ f_ext_journal.2.log	2020-07-28 10:48:11.638588000 +0000
@@ -1,7 +1,2 @@
-Pass 1: Checking inodes, blocks, and sizes
-Pass 2: Checking directory structure
-Pass 3: Checking directory connectivity
-Pass 4: Checking reference counts
-Pass 5: Checking group summary information
-test_filesys: 89/2560 files (0.0% non-contiguous), 170/2560 blocks
-Exit status is 0
+Signal (11) SIGSEGV si_code=SEGV_MAPERR fault addr=0x1000
+Exit status is 8

==> /usr/ports/sysutils/e2fsprogs/work/e2fsprogs-1.45.6/tests/j_corrupt_ext_jnl_sb_csum.failed <==
--- j_corrupt_ext_jnl_sb_csum/expect	2020-03-21 04:24:04.000000000 +0000
+++ j_corrupt_ext_jnl_sb_csum.log	2020-07-28 10:49:34.812519000 +0000
@@ -1,27 +1,7 @@
 External journal superblock checksum does not match superblock.  Fix? yes
 
 test_filesys: recovering journal
-Pass 1: Checking inodes, blocks, and sizes
-Pass 2: Checking directory structure
-Pass 3: Checking directory connectivity
-Pass 4: Checking reference counts
-Pass 5: Checking group summary information
-Block bitmap differences:  +(1--31) +34 +(50--82)
-Fix? yes
-
-Inode bitmap differences:  +(1--11)
-Fix? yes
-
-Padding at end of inode bitmap is not set. Fix? yes
-
-
-test_filesys: ***** FILE SYSTEM WAS MODIFIED *****
-test_filesys: 11/128 files (0.0% non-contiguous), 66/2048 blocks
-Exit status is 1
-Pass 1: Checking inodes, blocks, and sizes
-Pass 2: Checking directory structure
-Pass 3: Checking directory connectivity
-Pass 4: Checking reference counts
-Pass 5: Checking group summary information
-test_filesys: 11/128 files (0.0% non-contiguous), 66/2048 blocks
-Exit status is 0
+Signal (11) SIGSEGV si_code=SEGV_MAPERR fault addr=0x1000
+Exit status is 8
+Signal (11) SIGSEGV si_code=SEGV_MAPERR fault addr=0x1000
+Exit status is 8

==> /usr/ports/sysutils/e2fsprogs/work/e2fsprogs-1.45.6/tests/j_ext_long_revoke_trans.failed <==
--- j_ext_long_revoke_trans/expect	2020-03-21 04:24:04.000000000 +0000
+++ j_ext_long_revoke_trans.log	2020-07-28 10:49:44.074822000 +0000
@@ -15,13 +15,8 @@
 Filesystem features: has_journal ext_attr resize_inode dir_index filetype extent flex_bg sparse_super huge_file uninit_bg dir_nlink extra_isize
 debugfs: ssv journal_dev 0x9999
 debugfs: ssv journal_uuid 1db3f677-6832-4adb-bafc-8e4059c30a34
-Pass 1: Checking inodes, blocks, and sizes
-Pass 2: Checking directory structure
-Pass 3: Checking directory connectivity
-Pass 4: Checking reference counts
-Pass 5: Checking group summary information
-test_filesys: 11/16384 files (0.0% non-contiguous), 6239/262144 blocks
-Exit status is 0
+Signal (11) SIGSEGV si_code=SEGV_MAPERR fault addr=0x1000
+Exit status is 8
 debugfs write journal
 debugfs: logdump -c
 Ext2 superblock header found.
@@ -82,10 +77,5 @@
 No magic number at block 4154: end of journal.
 debugfs fsck
 test_filesys: recovering journal
-Pass 1: Checking inodes, blocks, and sizes
-Pass 2: Checking directory structure
-Pass 3: Checking directory connectivity
-Pass 4: Checking reference counts
-Pass 5: Checking group summary information
-test_filesys: 11/16384 files (0.0% non-contiguous), 6239/262144 blocks
-Exit status is 0
+Signal (11) SIGSEGV si_code=SEGV_MAPERR fault addr=0x1000
+Exit status is 8

==> /usr/ports/sysutils/e2fsprogs/work/e2fsprogs-1.45.6/tests/j_ext_long_trans.failed <==
--- j_ext_long_trans/expect	2020-03-21 04:24:04.000000000 +0000
+++ j_ext_long_trans.log	2020-07-28 10:49:54.322958000 +0000
@@ -15,13 +15,8 @@
 Filesystem features: has_journal ext_attr resize_inode dir_index filetype extent flex_bg sparse_super huge_file uninit_bg dir_nlink extra_isize
 debugfs: ssv journal_dev 0x9999
 debugfs: ssv journal_uuid 1db3f677-6832-4adb-bafc-8e4059c30a34
-Pass 1: Checking inodes, blocks, and sizes
-Pass 2: Checking directory structure
-Pass 3: Checking directory connectivity
-Pass 4: Checking reference counts
-Pass 5: Checking group summary information
-test_filesys: 11/16384 files (0.0% non-contiguous), 6239/262144 blocks
-Exit status is 0
+Signal (11) SIGSEGV si_code=SEGV_MAPERR fault addr=0x1000
+Exit status is 8
 debugfs write journal
 debugfs: logdump -c
 Ext2 superblock header found.
@@ -64,43 +59,5 @@
 No magic number at block 4136: end of journal.
 debugfs fsck
 test_filesys: recovering journal
-Resize inode not valid.  Recreate? yes
-
-Pass 1: Checking inodes, blocks, and sizes
-Root inode is not a directory.  Clear? yes
-
-Pass 2: Checking directory structure
-Pass 3: Checking directory connectivity
-Root inode not allocated.  Allocate? yes
-
-/lost+found not found.  Create? yes
-
-Pass 4: Checking reference counts
-Pass 5: Checking group summary information
-Block bitmap differences:  +(1--259) +275 +(291--418) +2341
-Fix? yes
-
-Free blocks count wrong for group #0 (5838, counted=5851).
-Fix? yes
-
-Free blocks count wrong (255903, counted=255916).
-Fix? yes
-
-Inode bitmap differences:  +1 +(3--10)
-Fix? yes
-
-Free inodes count wrong for group #0 (500, counted=501).
-Fix? yes
-
-Directories count wrong for group #0 (3, counted=2).
-Fix? yes
-
-Free inodes count wrong (16372, counted=16373).
-Fix? yes
-
-Padding at end of inode bitmap is not set. Fix? yes
-
-
-test_filesys: ***** FILE SYSTEM WAS MODIFIED *****
-test_filesys: 11/16384 files (0.0% non-contiguous), 6228/262144 blocks
-Exit status is 1
+Signal (11) SIGSEGV si_code=SEGV_MAPERR fault addr=0x1000
+Exit status is 8
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/sysutils/e2fsprogs
*** Error code 1

Stop.
make: stopped in /usr/ports/sysutils/e2fsprogs


Full build log attached.
Comment 1 Matthias Andree freebsd_committer 2020-07-28 21:27:30 UTC
I am routinely testing in 12.1-RELEASE jail(8)s, and have not received other reports of self-test failures aside from this one, and no fallout mail from the builders.

The addr=0x1000 looks suspicious. 

Can you run a memory and other available hardware tests, possibly tune down timing, check for BIOS updates, stop overclocking, try taking out memory modules from the computer (powered down, of course) if that's a supported configuration on your mainboard and put them back one by one or in pairs, and see if the error goes away? Check fans and coolers, proper seating of plugs and whatnot, and anything else to rule out hardware trouble.

If you have another computer handy, try building on that one (but do NOT mount the mass storage from your failing computer to another one to reproduce the software - if there is really a memory or other hardware fault, the mass storage from the defective computer might be spoiled).

I'll close this as unable to reproduce, and we'll need stack backtraces and other details to verify it's really a software fault, and not something on your end. In that case, and only with stack backtraces of the failing executables, feel free to reopen the PR.
Comment 2 gja822 2020-07-29 05:09:06 UTC
(In reply to Matthias Andree from comment #1)
I am on (supported version) 12.1-STABLE r363632 amd64.

No other troubling ports at the moment than sysutils/e2fsprogs.

No overclocking at all, the latest BIOS, memory checked and working O.K. The coolers cools nicely:
$ sysctl dev.cpu.0.freq dev.aibs.0.temp dev.cpu.0.temperature
dev.cpu.0.freq: 3300
dev.aibs.0.temp.0: 47.0C 60.0C 95.0C
dev.aibs.0.temp.1: 36.0C 45.0C 75.0C
, the computer almost idle during this tests:
Mem: 1019M Active, 11G Inact, 707M Laundry, 2206M Wired, 1287M Buf, 422M Free
Swap: 6144M Total, 70M Used, 6074M Free, 1% Inuse

  PID USERNAME    PRI NICE   SIZE    RES STATE    C   TIME    WCPU COMMAND
43272 root        103    0    13M  3980K CPU3     3   7:15  99.90% debugfs
   10 root        155 ki31     0B   128K CPU2     2 877:39  99.61% idle{idle: cpu2}
   10 root        155 ki31     0B   128K CPU6     6 944:26  95.91% idle{idle: cpu6}
   10 root        155 ki31     0B   128K CPU0     0 884:17  95.86% idle{idle: cpu0}
   10 root        155 ki31     0B   128K CPU4     4 881:12  94.41% idle{idle: cpu4}
   10 root        155 ki31     0B   128K RUN      7 908:47  94.14% idle{idle: cpu7}
   10 root        155 ki31     0B   128K CPU1     1 890:13  92.48% idle{idle: cpu1}
   10 root        155 ki31     0B   128K CPU5     5 884:34  86.03% idle{idle: cpu5}

No, I do not have an another computer handy at the moment and I do not have an another computer with the exact configuration of installed software and hardware at all.

As you could see from my build log I have SLOWTESTS=on.

The backtrace of dumped core file is meaningless, unless you could explain me how it could help without any symbol information. Or may be I mean something wrong when read "stack backtrace".

But thank you for the reply and support. Had to rebuild all the dependencies of the port:
portupgrade -f e2fsprogs-libuuid-1.45.6 e2fsprogs-libss-1.45.6 e2fsprogs-libblkid-1.45.6_1
although their versions did not changed (such as e2fsprogs-1.45.6_3 did not changed, but I wanted to rebuild it when installed fusefs-ext2-0.0.10_2 as e2fsprogs-1.45.6_3 is its direct dependency) and now it passes tests phase without error. So, if I did not try to voluntarily rebuild e2fsprogs-1.45.6_3 I could not find this hanging problem with newly installed fusefs-ext2-0.0.10_2.

Sorry for the disturbance,
Thank you for your scrupulous support,
sincerely your, Yury

> The addr=0x1000 looks suspicious.
Comment 3 Matthias Andree freebsd_committer 2020-07-30 11:45:45 UTC
I have just tried "make check WITH_DEBUG=yes" and other than f_large_dir being killed because it is just way too slow on my virtual machine and gets killed (with SIGKILL) eventually, I see no SIGSEGV, SIGABRT, or similar.

WITH_DEBUG=yes should include the symbols so as to make backtraces useful. 

You may need to re-build and re-install the e2fsprogs-lib* ports under WITH_DEBUG=yes.

So I really don't know where to look.
Comment 4 gja822 2020-07-30 16:41:12 UTC
(In reply to Matthias Andree from comment #3)
Thank you for your concern.
The information on debug is very useful.
My problem was solved by rebuilding dependencies, namely e2fsprogs-libuuid, e2fsprogs-libss and e2fsprogs-libblkid.