Bug 248339 - emulators/virtualbox-ose-kmod: Kernel panic on 13-CURRENT when using bridge mode
Summary: emulators/virtualbox-ose-kmod: Kernel panic on 13-CURRENT when using bridge mode
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kubilay Kocak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-29 04:38 UTC by Neel Chauhan
Modified: 2020-07-30 23:15 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback+


Attachments
Stack trace (149.55 KB, image/jpeg)
2020-07-29 04:40 UTC, Neel Chauhan
no flags Details
Patch (1.77 KB, patch)
2020-07-29 05:04 UTC, Neel Chauhan
no flags Details | Diff
Patch (Revision 2) (1.87 KB, patch)
2020-07-29 15:19 UTC, Neel Chauhan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Neel Chauhan 2020-07-29 04:38:19 UTC
When I use VirtualBox on 13-CURRENT r363508, and attempt to use a bridged network, I get a kernel panic. This issue doesn't exist on 12.x.

System:
HP Spectre x360 13-ap0053dx
Intel Core i7-8565U
16GB DDR4
512GB NVMe + Intel Optane
13" 4K Touchscreen
Intel AC-9560 (iwm)

Stack trace is attached as a jpg.
Comment 1 Neel Chauhan 2020-07-29 04:38:31 UTC
*** Bug 244819 has been marked as a duplicate of this bug. ***
Comment 2 Neel Chauhan 2020-07-29 04:40:32 UTC
Created attachment 216847 [details]
Stack trace
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2020-07-29 04:51:44 UTC
@Neel Can you include your latest comment and attachment to bug 244819 please

*** This bug has been marked as a duplicate of bug 244819 ***
Comment 4 Neel Chauhan 2020-07-29 05:04:21 UTC
Created attachment 216848 [details]
Patch

VirtualBox does not use EPOCH on 13, so this patch adds support for EPOCH in VirtualBox.
Comment 5 Neel Chauhan 2020-07-29 05:04:47 UTC
Accidentally closed this.
Comment 6 Neel Chauhan 2020-07-29 05:05:27 UTC
*** Bug 244819 has been marked as a duplicate of this bug. ***
Comment 7 Neel Chauhan 2020-07-29 05:05:46 UTC
(In reply to Neel Chauhan from comment #5)
well, didn't read your comment, sorry.
Comment 8 Kubilay Kocak freebsd_committer freebsd_triage 2020-07-29 05:07:06 UTC
Bug 244819 is a report of a freeze, not panic, not technically a duplicate. Are the freeze symptoms still reproducible, or is it *now* a crash?
Comment 9 Neel Chauhan 2020-07-29 05:17:41 UTC
It technically is a panic, it just appears as a freeze with Nvidia graphics which my desktop use (the prior ProDesk mentioned and my current HP Omen).

I called a freeze since I didn't investigate further. I now know it is a panic.

BTW the patch is for emulators/virtualbox-ose-kmod.
Comment 10 Neel Chauhan 2020-07-29 15:19:48 UTC
Created attachment 216862 [details]
Patch (Revision 2)

The patch should go into emulators/virtualbox-ose, as emulators/virtualbox-ose-kmod picks up the former's files.

This is a full patch.

I confirm this working, even on the previously "freezing" computers (Nvidia graphics) and the panic computers (Intel graphics).