Bug 248341 - mail/phpmailer6: Fails to package with NLS=off: phpmailer.lang-af.php:No such file or directory
Summary: mail/phpmailer6: Fails to package with NLS=off: phpmailer.lang-af.php:No such...
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jochen Neumeister
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2020-07-29 08:56 UTC by Andrej Ebert
Modified: 2020-09-03 22:08 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (joneum)
koobs: merge-quarterly?


Attachments
svn diff (4.47 KB, patch)
2020-07-29 08:56 UTC, Andrej Ebert
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andrej Ebert 2020-07-29 08:56:35 UTC
Created attachment 216852 [details]
svn diff

If the NLS option is unset, the pkg install throws errors like:

pkg-static: Unable to access file /usr/ports/mail/phpmailer6/work/stage/usr/local/share/phpmailer/language/phpmailer.lang-af.php:No such file or directory

for all the language files.

The attached patch fixes the pkg-plist, making the install of language files conditional on the NLS option.
Comment 1 Jochen Neumeister freebsd_committer 2020-09-03 22:08:16 UTC
%%NLS%% cannot work because it is not defined in the Makefile. I can install it without problems with "pkg install".

if you think it is an mistake, open the pr again.