Bug 248364 - mail/postfix-current-sasl: does not build with DEFAULT_VERSIONS+=ssl=openssl
Summary: mail/postfix-current-sasl: does not build with DEFAULT_VERSIONS+=ssl=openssl
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Olli Hauer
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2020-07-30 11:11 UTC by Gerard Seibert
Modified: 2020-08-01 04:51 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (ohauer)
koobs: merge-quarterly?


Attachments
Postfix Build Log (9.70 KB, text/plain)
2020-07-30 11:11 UTC, Gerard Seibert
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerard Seibert 2020-07-30 11:11:00 UTC
Created attachment 216881 [details]
Postfix Build Log

FreeBSD 11.4-RELEASE-p1 amd64

I am unable to build 'postfix-current-sasl'. It has always built successfully prior to the latest update. The poudriere log file for the build is attached.

The build ends with this error:

=======================<phase: check-sanity   >============================
Ignoring: is marked as broken: does not build with DEFAULT_VERSIONS+=ssl=openssl
===========================================================================
build of mail/postfix-current-sasl | postfix-current-sasl-3.6.20200725,6 ended at Thu Jul 30 05:56:34 EDT 2020
Comment 1 commit-hook freebsd_committer 2020-07-31 20:41:06 UTC
A commit references this bug:

Author: ohauer
Date: Fri Jul 31 20:40:47 UTC 2020
New revision: 543882
URL: https://svnweb.freebsd.org/changeset/ports/543882

Log:
  - allow build on FreeBSD 11 with openssl from ports [1]
  - remove TLS_USES = ssl, since USES = ssl already defined

  PR:		[1] 248364
  Reported by:	Gerard Seiber and Michael Grimm

Changes:
  head/mail/postfix-current/Makefile