Bug 248366 - Bad performance Zvols+CTLD with windows clients
Summary: Bad performance Zvols+CTLD with windows clients
Status: Closed DUPLICATE of bug 248342
Alias: None
Product: Documentation
Classification: Unclassified
Component: Documentation (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-doc (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-30 11:28 UTC by Евгений
Modified: 2020-07-30 12:14 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Евгений 2020-07-30 11:28:07 UTC
English version:
Good day. We have a problem with zvols. Zvol's clones giving through ctld (100 clients). There is freeze in Windows client on 5-10 seconds, respectively clients NTFS Windows are under zfs zvols. Problem begining when we destroyd old clones and snapshots and maked new snapshots and clones.

uname -a
FreeBSD bsd 11.2-RELEASE FreeBSD 11.2-RELEASE #0 r335510: Fri Jun 22 04:32:14 UTC 2018     root@releng2.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64

Configuration zpool: 
atime=off dedup=off sync=disabled compression=lz4
Configuration CTLD:
portal-group test {
 discovery-auth-group no-authentication
 listen 192.168.173.206:3260
}
target iqn.orig1 {
auth-group no-authentication
portal-group test
lun 0 {
path /dev/zvol/ssd/orig/original1
ctl-lun 194
}}
target iqn.orig2 {
auth-group no-authentication
portal-group test
lun 0 {
path /dev/zvol/ssd/orig/original2
ctl-lun 195
}}
target iqn.orig3 {
auth-group no-authentication
portal-group test
lun 0 { 
path /dev/zvol/ssd/orig/original3
ctl-lun 196 }}
target iqn.orig4 {
auth-group no-authentication
portal-group test
lun 0 { 
path /dev/zvol/ssd/orig/original4
ctl-lun 198 }}
target iqn.games {
auth-group no-authentication
portal-group test
lun 0 { 
path /dev/zvol/hdd/orig/games
ctl-lun 197 }}


target iqn.pc1 { 
auth-group no-authentication 
portal-group test
lun 0 { 
path /dev/zvol/ssd/snap/win1 
ctl-lun 1}
lun 1 { 
path /dev/zvol/hdd/snap/win1 
ctl-lun 101}}
target iqn.pc2 { 
auth-group no-authentication 
portal-group test 
lun 0 { 
path /dev/zvol/ssd/snap/win2 
ctl-lun 2}
lun 1 { 
path /dev/zvol/hdd/snap/win2 
ctl-lun 102}}

So until iqn.pc100.
We tried on the difference hardware and Windows clients, but problem didnt solve. Windows clients always configured for performance.
Piece of script destroy/make snap and clones:

ctladm remove -b block -l $name 
cat /dev/null > /var/log/xferlog
zfs destroy -R ssd/orig/original$c@win$name
zfs snap ssd/orig/original$c@win$name
zfs clone ssd/orig/original$c@win$name ssd/snap/win$name
ctladm create -b block -l $name -o file=/dev/zvol/ssd/snap/win$name 

Hardware:
Intel Xeon E5-2620
128Gb DDR3 ECC REG
SSD NVMe Samsung EVO 970 512Gb
SSD Intel DC4502 3.84Tb
NIC Mellanox ConnectX-2 10G SFP+

We believe on your help, becouse any ideas doesn't work.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2020-07-30 12:14:11 UTC

*** This bug has been marked as a duplicate of bug 248342 ***