Bug 248369 - ports-mgmt/modules2tuple: modules2tuple produces GH_TUPLE with missing elements
Summary: ports-mgmt/modules2tuple: modules2tuple produces GH_TUPLE with missing elements
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dmitri Goutnik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-30 17:43 UTC by Yuri Victorovich
Modified: 2020-07-31 01:44 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (dmgk)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2020-07-30 17:43:03 UTC
I am trying to update the port devel/git-town. This patch https://people.freebsd.org/~yuri/git-town.patch contains exact GH_TUPLE that modules2tuple suggested. But the build fails:

> can't load package: package stretchr: cannot find package "." in:
> 	/usr/ports/devel/git-town/work/git-town-7.4.0/vendor/stretchr
> *** Error code 1
Comment 1 Yuri Victorovich freebsd_committer 2020-07-31 01:44:38 UTC
Not a bug in ports-mgmt/modules2tuple.

Removal of GH_SUBDIR fixes the port.

Thanks, Dmitri!