Bug 248382 - databases/rrdtool rc variable rrdcached_flags no longer usable
Summary: databases/rrdtool rc variable rrdcached_flags no longer usable
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Niclas Zeising
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-31 09:35 UTC by Rudolph
Modified: 2020-08-13 16:26 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (zeising)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rudolph 2020-07-31 09:35:30 UTC
The rrdcached rc script has been updated in https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=246122

I like the change, but now I do not have the option to provide extra flags. rrdcached_flags is still mentioned in the comments, please re-add it to command_args.
Comment 1 Niclas Zeising freebsd_committer 2020-08-13 16:26:52 UTC
Hi!
rrdcached_flags, if defined, is automatically added to the command line by the rc infrastructure, there is no need to add it explicitly to command_args.

Are you having trouble getting extra arguments passed to rrdcached?  If so, verify that rrdcached_flags in /etc/rc.conf is spelled correctly, and set rc_debug="YES" in /etc/rc.conf and verify what the command line for starting rrdcaced looks like.