Bug 248453 - databases/cassandra3: fix 13-current build (devel/sigar is broken)
Summary: databases/cassandra3: fix 13-current build (devel/sigar is broken)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Fernando Apesteguía
URL:
Keywords:
Depends on: 248460
Blocks:
  Show dependency treegraph
 
Reported: 2020-08-03 12:54 UTC by Ronald Klop
Modified: 2020-08-13 12:32 UTC (History)
2 users (show)

See Also:
language.devel: maintainer-feedback+


Attachments
disable OPTION SIGAR on 13 (svn diff to the databases/ dir) (1015 bytes, patch)
2020-08-03 12:54 UTC, Ronald Klop
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ronald Klop 2020-08-03 12:54:42 UTC
Created attachment 216990 [details]
disable OPTION SIGAR on 13 (svn diff to the databases/ dir)

I noticed cassandra3/4 is not build on 13-current. It does build on 11 and 12.
The cause is breakage in the devel/sigar port on 13-current. It is a fairly recent breakage.
 
works: http://beefy18.nyi.freebsd.org/data/head-amd64-default/p541901_s363088/logs/sigar-1.7.3_2.log
 
broken: http://beefy18.nyi.freebsd.org/data/head-amd64-default/p543559_s363627/logs/errors/sigar-1.7.3_2.log

broken also: http://thunderx1.nyi.freebsd.org/data/head-arm64-default/p542683_s363381/logs/errors/sigar-1.7.3_2.log

The error seems to be in a missing sys/filedesc.h include. This is a big guess of my side.
darwin_sigar.c:1968:27: error: no member named 'fd_lastfile' in 'struct filedesc'
    procfd->total = filed.fd_lastfile;
 
I noticed the working build is in Jail OSVERSION: 1300101 and the broken one is in Jail OSVERSION: 1300101.
I'm wondering if it is possible to get a more fine grained version nr of the working/broken version. And while I'm typing this I see that the URLs contain s363088 and s363381. So this narrows it down to about 300 commits *if* the cause is in the FreeBSD source.

In the meantime I have a patch to disable the dependency on "sigar" on FreeBSD 13. The patch does not change anything on 11 and 12.
If somebody comes up with a patch for devel/sigar we can enable this option again.

The patch is for cassandra4 also.
Comment 1 Ronald Klop 2020-08-03 12:56:09 UTC
BTW, the http://beefy18.nyi.freebsd.org URLs are IPv6 only. Safes you some time figuring that out.
Comment 2 Angelo Polo 2020-08-03 13:28:53 UTC
This probably doesn't help with the sys/filedesc.h problem, but I did create bug #245867 to update SIGAR to be at least Java 11 compatible, run tests (helpful for working any further updates), and eliminate a big dependency.
Comment 3 Ronald Klop 2020-08-03 22:53:56 UTC
I created bug #248460 with a possible fix to devel/sigar.
Comment 4 Fernando Apesteguía freebsd_committer 2020-08-13 09:48:02 UTC
devel/sigar fixed in bug #248460

databases/cassandra3 builds now fine in {11.4,12.1}{amd64,i386} and 13-current amd64 in r364141
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2020-08-13 12:32:02 UTC
^Triage: Track the issue dependency that resolving this issue depended on