Bug 248466 - net-mgmt/net-snmp: sampleize newsyslog.conf
Summary: net-mgmt/net-snmp: sampleize newsyslog.conf
Status: Closed DUPLICATE of bug 248058
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Ryan Steinmetz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-04 13:31 UTC by Dries Michiels
Modified: 2020-08-09 07:43 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (zi)


Attachments
net-snmp.diff (2.24 KB, patch)
2020-08-04 13:31 UTC, Dries Michiels
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dries Michiels 2020-08-04 13:31:47 UTC
Created attachment 217003 [details]
net-snmp.diff

The initial idea for making an option out of NEWSYSLOG was to allow users to (remove in this case) or modify it without getting checksum complaints of the package at hand. The downside is that one needs to build from ports with the option disabled to get that benefit. One reason to modify thta file might be you are running ZFS with compression on and you do not want the log file rotated to be compressed again (which is the default). By making a sample out of it, the user can alter the original non .sample file to its liking without getting checksum errors in the package.

PS: One idea might to to completely remove the option after this change, although I wonder if this breaks POLA or not.

PS: I'm not sure what the behavior is of including two identical newsyslog.conf.d files in newsyslog.conf without being on 13-CURRENT, where only .conf files are included in newsyslog.conf and not all files including .sample files.
Comment 1 Dries Michiels 2020-08-04 13:33:20 UTC
I did an "svn mv net-snmp.conf net-snmp.conf.sample" in the files directory.
It seems its not translated nicely in the patch attached.
Comment 2 James French 2020-08-09 00:36:47 UTC
(In reply to Dries Michiels from comment #1)

This is a duplicate of 248058
Comment 3 James French 2020-08-09 00:44:27 UTC
(In reply to Dries Michiels from comment #0)

In response to only .conf files being included by 13-CURRENT the behaviour in 12.1-RELEASE (and 11.4-RELEASE?) is all files in newsyslog.conf.d are included so the sample file has to be installed elsewhere, the patch I provided on the other bug installs it with the other sample config files.

Nice to see that we're both running into this one for the same reason though (ZFS)!
Comment 4 Dries Michiels 2020-08-09 07:43:46 UTC

*** This bug has been marked as a duplicate of bug 248058 ***