Bug 248503 - x11-toolkits/gtk-layer-shell requires gtk+-wayland-3.0
Summary: x11-toolkits/gtk-layer-shell requires gtk+-wayland-3.0
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-06 18:13 UTC by rkoberman
Modified: 2020-08-09 00:21 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (greg)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rkoberman 2020-08-06 18:13:35 UTC
The x11-toolkits/gtk-layer-shell port was updated to 0.2.0 but it is unbuildable as it requires gtk+-wayland-3.0. It was not available and I have no idea what port, if any, it comes from, but it is not a dependency in the Makeflle.

Using 'LDFLAGS' from environment with value: ' -fstack-protector-strong '
Using 'CPPFLAGS' from environment with value: ''
Using 'LDFLAGS' from environment with value: ' -fstack-protector-strong '
Run-time dependency gtk+-wayland-3.0 found: NO (tried pkgconfig and cmake)

meson.build:12:0: ERROR: Dependency "gtk+-wayland-3.0" not found, tried pkgconfig and cmake
Comment 1 Greg V 2020-08-07 00:25:41 UTC
Most likely your gtk30 package is built without WAYLAND option. (If this is intentional, gtk-layer-shell would not be useful to you in any way.)
Comment 2 Jan Beich freebsd_committer 2020-08-09 00:21:57 UTC
Whatever requires gtk-layer-shell probably needs to be put inside WAYLAND option e.g., ports r540061. Mixing WAYLAND-enabled and WAYLAND-disabled packages is not well-supported but the same is true for mixing X11-enabled and X11-disabled packages. The reason is simple: FreeBSD Ports unlike Gentoo doesn't support requesting a dependency built with a specific option enabled/disabled.