Bug 248520 - graphics/qt5-imageformats 5.15.0 fails to build: Missing dependency 'gettext-runtime'
Summary: graphics/qt5-imageformats 5.15.0 fails to build: Missing dependency 'gettext-...
Status: Closed DUPLICATE of bug 248521
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-kde (Team)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-07 22:59 UTC by p5B2E9A8F
Modified: 2020-08-08 06:29 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (kde)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description p5B2E9A8F 2020-08-07 22:59:32 UTC
===>   qt5-imageformats-5.15.0 depends on shared library: libjasper.so - found (/usr/local/lib/libjasper.so)
===>   Returning to build of qt5-imageformats-5.15.0
===>   qt5-imageformats-5.15.0 depends on shared library: libmng.so - not found
===>   Installing existing package /packages/All/libmng-1.0.10_3.txz
[12i386-default-bpbws41-job-08] Installing libmng-1.0.10_3...
[12i386-default-bpbws41-job-08] `-- Installing lcms-1.19_6,1...
[12i386-default-bpbws41-job-08] |   `-- Installing tiff-4.1.0...
[12i386-default-bpbws41-job-08] |   | `-- Installing jbigkit-2.1_1...
[12i386-default-bpbws41-job-08] |   | `-- Extracting jbigkit-2.1_1: .......... done
[12i386-default-bpbws41-job-08] |   `-- Extracting tiff-4.1.0: .......... done
[12i386-default-bpbws41-job-08] `-- Extracting lcms-1.19_6,1: .......... done
[12i386-default-bpbws41-job-08] Extracting libmng-1.0.10_3: ......... done
===>   qt5-imageformats-5.15.0 depends on shared library: libmng.so - found (/usr/local/lib/libmng.so)
===>   Returning to build of qt5-imageformats-5.15.0
===>   qt5-imageformats-5.15.0 depends on shared library: libtiff.so - found (/usr/local/lib/libtiff.so)
===>   qt5-imageformats-5.15.0 depends on shared library: libwebp.so - not found
===>   Installing existing package /packages/All/webp-1.1.0.txz
[12i386-default-bpbws41-job-08] Installing webp-1.1.0...
[12i386-default-bpbws41-job-08] `-- Installing giflib-5.2.1...
[12i386-default-bpbws41-job-08] `-- Extracting giflib-5.2.1: .......... done
[12i386-default-bpbws41-job-08] `-- Installing png-1.6.37...
[12i386-default-bpbws41-job-08] `-- Extracting png-1.6.37: .......... done
[12i386-default-bpbws41-job-08] Extracting webp-1.1.0: .......... done
===>   qt5-imageformats-5.15.0 depends on shared library: libwebp.so - found (/usr/local/lib/libwebp.so)
===>   Returning to build of qt5-imageformats-5.15.0
===>   qt5-imageformats-5.15.0 depends on shared library: libQt5Core.so - not found
===>   Installing existing package /packages/All/qt5-core-5.15.0_2.txz
[12i386-default-bpbws41-job-08] Installing qt5-core-5.15.0_2...
[12i386-default-bpbws41-job-08] `-- Installing double-conversion-3.1.5.19...
[12i386-default-bpbws41-job-08] `-- Extracting double-conversion-3.1.5.19: .......... done
[12i386-default-bpbws41-job-08] `-- Installing etc_os-release-0.1_3...
[12i386-default-bpbws41-job-08] `-- Extracting etc_os-release-0.1_3: . done
pkg-static: Missing dependency 'gettext-runtime'

Failed to install the following 1 package(s): /packages/All/qt5-core-5.15.0_2.txz
*** Error code 70

Stop.
make: stopped in /usr/ports/graphics/qt5-imageformats
=>> Cleaning up wrkdir
===>  Cleaning for qt5-imageformats-5.15.0
build of graphics/qt5-imageformats | qt5-imageformats-5.15.0 ended at Sat Aug  8 00:49:26 CEST 2020
build time: 00:00:12
!!! build failure encountered !!!
Comment 1 Tobias C. Berner freebsd_committer 2020-08-08 06:29:21 UTC

*** This bug has been marked as a duplicate of bug 248521 ***