Bug 248528 - emulators/virtualbox-ose-additions: Build fails with 13-CURRENT base r363894
Summary: emulators/virtualbox-ose-additions: Build fails with 13-CURRENT base r363894
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: vbox (Nobody)
URL: https://reviews.freebsd.org/D26014
Keywords: needs-qa, regression
Depends on:
Blocks:
 
Reported: 2020-08-08 07:29 UTC by Yasuhiro KIMURA
Modified: 2020-08-13 19:45 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (vbox)
koobs: merge-quarterly?


Attachments
Fix build after r363893: vfs: remove the obsolete privused argument from vaccess (35.31 KB, patch)
2020-08-08 10:17 UTC, VVD
no flags Details | Diff
Fix build after r363893: vfs: remove the obsolete privused argument from vaccess (922 bytes, patch)
2020-08-10 16:46 UTC, VVD
vvd: maintainer-approval?
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 VVD 2020-08-08 10:17:22 UTC
Created attachment 217089 [details]
Fix build after r363893: vfs: remove the obsolete privused argument from vaccess

/wrkdirs/usr/ports/emulators/virtualbox-ose-additions/work/VirtualBox-5.2.44/src/VBox/Additions/freebsd/vboxvfs/vboxvfs_vnops.c:412:51: error: too many arguments to function call, expected 6, have 7
            node->vboxfsmp->sf_gid, accmode, ap->a_cred, NULL));
                                                         ^~~~
>        return (vaccess(vp->v_type, m, node->vboxfsmp->sf_uid,
>            node->vboxfsmp->sf_gid, accmode, ap->a_cred, NULL));

man vaccess (on 12.1):
     int
     vaccess(enum vtype type, mode_t file_mode, uid_t file_uid,
         gid_t file_gid, accmode_t accmode, struct ucred *cred,
         int *privused);

> After update 13-CURRENT to base r36403, build fails as following.
Date: 	Wed May 27 01:26:33 1998 UTC (22 years, 2 months ago)

This commit break build:
https://svnweb.freebsd.org/changeset/base/363893

Try to replace file emulators/virtualbox-ose/files/patch-src_VBox_Additions_freebsd_vboxvfs_vboxvfs__vnops.c with version in attach.
Comment 2 Guido Falsi freebsd_committer 2020-08-09 16:31:47 UTC
I have filed a patch here:

https://reviews.freebsd.org/D26014

My patch simply removes the extra NULL value to the privused argument.

I'd like to get approval to commit that review.
Comment 3 Guido Falsi freebsd_committer 2020-08-09 16:32:36 UTC
(In reply to Guido Falsi from comment #2)

I meant, simply removes it when building on recent current, obviously :)
Comment 4 VVD 2020-08-09 17:15:44 UTC
(In reply to Guido Falsi from comment #3)

           node->vboxfsmp->sf_gid, accmode, ap->a_cred
#if __FreeBSD_version < 1300105
           , NULL
#endif
           ));
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2020-08-10 03:53:28 UTC
@Guido Does your patch obsolete attachment 217089 [details]?
Comment 6 VVD 2020-08-10 16:35:24 UTC
(In reply to Kubilay Kocak from comment #5)
My patch applicable for 13 only - I made it for testing purposes only.

Guido's patch work for 11 and 12 too. But I wrote suggestion in comment #4 to his patch.
Comment 7 VVD 2020-08-10 16:46:58 UTC
Created attachment 217131 [details]
Fix build after r363893: vfs: remove the obsolete privused argument from vaccess

Patch with my suggestion to @Guido's patch.
Comment 8 Guido Falsi freebsd_committer 2020-08-11 08:04:29 UTC
(In reply to VVD from comment #7)

Thanks for the update, I've aligned the code review.
Comment 9 Yasuhiro KIMURA 2020-08-13 19:45:42 UTC
The problem is fixed with ports r544827.