Bug 248595 - net-im/jitsi-videobridge: Update to 2.1-273
Summary: net-im/jitsi-videobridge: Update to 2.1-273
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jose Alonso Cardenas Marquez
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2020-08-11 10:43 UTC by Dirk Meyer
Modified: 2021-01-31 14:05 UTC (History)
2 users (show)

See Also:
dinoex: maintainer-feedback-


Attachments
patch (1.63 KB, patch)
2020-08-11 10:43 UTC, Dirk Meyer
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Meyer freebsd_committer 2020-08-11 10:43:19 UTC
Created attachment 217150 [details]
patch

Update to stable release

dependencies generated by maven,
still need to be uploaded.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2020-08-13 04:39:09 UTC
^Triage: 

 - [tags] in issue Titles are deprecated
 - If there is a changelog or release notes URL available for this version, please add it to the URL field.
Comment 2 VVD 2021-01-29 10:52:22 UTC
> Resolution: --- → Overcome By Events
Are you working on newer version? Can I test it?

https://github.com/jitsi/jitsi-videobridge/releases
2.0.5390
@jitsi-jenkins jitsi-jenkins released this 17 days ago · 9 commits to master since this release
stable/jitsi-meet_5390

Current version in ports doesn't build:
[ERROR] Failed to execute goal on project jitsi-videobridge: Could not resolve dependencies for project org.jitsi:jitsi-videobridge:jar:2.1-SNAPSHOT: Cannot access jitsi-maven-repository-releases (https://github.com/jitsi/jitsi-maven-repository/raw/master/releases/) in offline mode and the artifact com.sun.activation:jakarta.activation:jar:1.2.1 has not been downloaded from it before. -> [Help 1]

Do you have "instruction" how to setup Jitsi server on FreeBSD?
Something like this:
https://jitsi.github.io/handbook/docs/devops-guide/devops-guide-manual
https://jitsi.github.io/handbook/docs/devops-guide/devops-guide-quickstart

Thanks!
Comment 3 Dirk Meyer freebsd_committer 2021-01-30 21:20:37 UTC
(In reply to VVD from comment #2)

I do not have an update,
I have a regression in newer version with binding to public IP and localhost.

Version in ports does still build with FreeBSD 12.2:
30 Jan. 13:31 /usr/ports/packages/All/jitsi-meet-1.0.4048_2.txz
30 Jan. 13:42 /usr/ports/packages/All/jicofo-1.0.555_2.txz
30 Jan. 13:43 /usr/ports/packages/All/jitsi-videobridge-2.1.183_3.txz

That version is able to run in jail.
Comment 4 VVD 2021-01-31 14:05:49 UTC
(In reply to Dirk Meyer from comment #3)
Where do you get configs?
For example sip-communicator.properties.
I updated ports to last tags, build and install. But I can't find good manual for configuring it…