Bug 248658 - stable/12 and releng/12.1 fail to build: missing definitions in sys/vm/vm_map.h later used in sys/vm/vm_map.c
Summary: stable/12 and releng/12.1 fail to build: missing definitions in sys/vm/vm_map...
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 12.1-STABLE
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2020-08-14 14:18 UTC by dmilith
Modified: 2020-08-14 15:01 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback? (markj)
koobs: maintainer-feedback? (dougm)
koobs: mfc-stable12?


Attachments
Patch fixing the build. (626 bytes, patch)
2020-08-14 14:18 UTC, dmilith
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description dmilith 2020-08-14 14:18:46 UTC
Created attachment 217212 [details]
Patch fixing the build.

Build problem caused by missing definitions in sys/vm/vm_map.h later used in sys/vm/vm_map.c
Comment 1 Mark Johnston freebsd_committer 2020-08-14 14:48:24 UTC
This doesn't make sense to me.  What branch are you trying to build, and what version are you trying to build on?  That patch isn't going to apply to head or stable/12 or releng/12.1.
Comment 2 dmilith 2020-08-14 15:01:37 UTC
(In reply to Mark Johnston from comment #1)
I'm sorry, after further investigation it turned out to be mismerge on local git repository cache.