Bug 248669 - editors/libreoffice: Build crashed on 12.1-RELEASE-p8
Summary: editors/libreoffice: Build crashed on 12.1-RELEASE-p8
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: FreeBSD Office Team
URL:
Keywords: crash, needs-qa
Depends on:
Blocks:
 
Reported: 2020-08-15 10:22 UTC by vgBSD
Modified: 2020-08-16 13:14 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (office)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vgBSD 2020-08-15 10:22:29 UTC
FreeBSD 12.1-RELEASE-p8 GENERIC  amd64
Update libreoffice 6.4.5 -> 6.4.6.
#portmaster libreoffice
...
[CXX] svx/source/sdr/contact/viewcontactofsdrmeasureobj.cxx
c++: error: unable to execute command: Segmentation fault (core dumped)
c++: error: clang frontend command failed due to signal (use -v to see invocation)
FreeBSD clang version 8.0.1 (tags/RELEASE_801/final 366581) (based on LLVM 8.0.1)
Target: x86_64-unknown-freebsd12.1
Thread model: posix
InstalledDir: /usr/bin
c++: note: diagnostic msg: PLEASE submit a bug report to https://bugs.freebsd.org/submit/ and include the crash backtrace, preprocessed source, and associated run script.
c++: note: diagnostic msg: 
********************

PLEASE ATTACH THE FOLLOWING FILES TO THE BUG REPORT:
Preprocessed source(s) and associated run script(s) are located at:
c++: note: diagnostic msg: /tmp/usr/ports/editors/libreoffice/work/objectcontactofpageview-1ce570.cpp
c++: note: diagnostic msg: /tmp/usr/ports/editors/libreoffice/work/objectcontactofpageview-1ce570.sh
c++: note: diagnostic msg: 

********************
gmake[3]: *** [/tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/solenv/gbuild/LinkTarget.mk:296: /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CxxObject/svx/source/sdr/contact/objectcontactofpageview.o] Error 254
gmake[3]: *** Waiting for unfinished jobs....
rm /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/dict_word_nodash.brk /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/line.txt /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/count_word.txt /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/line.brk /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/edit_word_hu.brk /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/edit_word.brk /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/dict_word_hu.brk /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/dict_word_hu.txt /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/char.brk /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/sent.txt /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/dict_word.txt /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/dict_word.brk /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/edit_word_he.brk /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/sent.brk /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/edit_word.txt /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/dict_word_prepostdash.txt /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/dict_word_prepostdash.brk /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/char_in.brk /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/dict_word_nodash.txt /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/dict_word_he.brk /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/dict_word_he.txt /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/char_in.txt /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/char.txt /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/edit_word_he.txt /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/edit_word_hu.txt /tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2/workdir/CustomTarget/i18npool/breakiterator/count_word.brk
gmake[3]: Leaving directory '/tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2'
gmake[2]: *** [Makefile:282: build] Error 2
gmake[2]: Leaving directory '/tmp/usr/ports/editors/libreoffice/work/libreoffice-6.4.6.2'
===> Compilation failed unexpectedly.

===> The following configuration options are available for libreoffice-6.4.6:
     CUPS=on: CUPS printing system support
     DOCS=on: Build and/or install documentation
     GNOME=off: GNOME desktop environment support
     GTK3=off: GTK+ 3 GUI toolkit support (broken visual style)
     JAVA=off: Add Java support (XML filters, macros, DB connections)
     KF5=off: KF5/Qt5 GUI toolkit support (implies QT5)
     MMEDIA=off: Enable multimedia backend for Impress
     PGSQL=off: Build with PostgreSQL-SDBC driver
     QT5=on: Qt5 GUI toolkit support (default visual style)
     SDK=off: Build with SDK
     TEST=off: Run all regression tests
     WEBDAV=off: Enable WebDAV protocol
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2020-08-15 10:30:36 UTC
@Reporter Can you attach the files mentioned in the error report please. Without them we'll be unable to diagnose potential issues.

Can you please also include /etc/make.conf contents if not empty
Comment 2 VVD 2020-08-15 13:19:18 UTC
(In reply to vgBSD from comment #0)
And check with gdb this core dump:
> c++: error: unable to execute command: Segmentation fault (core dumped)
For example:
# gdb /usr/bin/c++ /tmp/usr/ports/editors/libreoffice/work/c++.core
(gdb) bt
Comment 3 Mikael Urankar freebsd_committer 2020-08-15 17:06:46 UTC
(In reply to vgBSD from comment #0)
c++: error: clang frontend command failed due to signal

was it killed due to OOM?
Comment 4 VVD 2020-08-15 19:41:03 UTC
Out of memory - check in /var/log/messages
Comment 5 vgBSD 2020-08-16 12:13:06 UTC
Thanks.
Today build and installed no problem.
I am sorry for disturbing.
Comment 6 VVD 2020-08-16 12:32:53 UTC
(In reply to vgBSD from comment #5)
Then close the bug report.