Bug 248729 - databases/gdbm: Fix build with -fno-common (default after llvm 11 update in CURRENT)
Summary: databases/gdbm: Fix build with -fno-common (default after llvm 11 update in C...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Alexey Dokuchaev
URL:
Keywords: easy, patch-ready
: 248734 (view as bug list)
Depends on:
Blocks: 248756
  Show dependency treegraph
 
Reported: 2020-08-18 17:43 UTC by Niclas Zeising
Modified: 2020-08-19 17:42 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (danfe)
zeising: merge-quarterly?


Attachments
v1 (764 bytes, patch)
2020-08-18 17:43 UTC, Niclas Zeising
zeising: maintainer-approval?
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Niclas Zeising freebsd_committer 2020-08-18 17:43:32 UTC
Created attachment 217315 [details]
v1

Attached patch fixes the build of dtabases/gdbm after llvm 11 update, which enabled -fno-common by default.
Comment 1 Niclas Zeising freebsd_committer 2020-08-18 23:29:04 UTC
*** Bug 248734 has been marked as a duplicate of this bug. ***
Comment 2 commit-hook freebsd_committer 2020-08-19 07:57:59 UTC
A commit references this bug:

Author: danfe
Date: Wed Aug 19 07:57:32 UTC 2020
New revision: 545278
URL: https://svnweb.freebsd.org/changeset/ports/545278

Log:
  - Fix the build with -fno-common (clang 11 and gcc 10)
  - GC no longer useful patching of ${WRKSRC}/Makefile.in

  PR:	248729, 248734

Changes:
  head/databases/gdbm/Makefile
Comment 3 Alexey Dokuchaev freebsd_committer 2020-08-19 07:59:10 UTC
Committed using the sed(1) approach, thanks.