Bug 248734 - databases/gdbm: Fix build with -fno-common (clang 11 and gcc 10)
Summary: databases/gdbm: Fix build with -fno-common (clang 11 and gcc 10)
Status: Closed DUPLICATE of bug 248729
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Alexey Dokuchaev
URL:
Keywords:
Depends on:
Blocks: 248756
  Show dependency treegraph
 
Reported: 2020-08-18 21:11 UTC by Dimitry Andric
Modified: 2020-08-19 17:42 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (danfe)


Attachments
Fix build with -fno-common (clang 11 and gcc 10) (972 bytes, patch)
2020-08-18 21:11 UTC, Dimitry Andric
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitry Andric freebsd_committer 2020-08-18 21:11:13 UTC
Created attachment 217319 [details]
Fix build with -fno-common (clang 11 and gcc 10)

In base r364284, I imported clang 11 into head. Like gcc 10, it now defaults to -fno-common, meaning that duplicated global symbols will most likely lead to link errors. Here is a patch to fix this port's duplicated global symbols.
Comment 1 Niclas Zeising freebsd_committer 2020-08-18 23:29:04 UTC

*** This bug has been marked as a duplicate of bug 248729 ***
Comment 2 commit-hook freebsd_committer 2020-08-19 07:58:00 UTC
A commit references this bug:

Author: danfe
Date: Wed Aug 19 07:57:32 UTC 2020
New revision: 545278
URL: https://svnweb.freebsd.org/changeset/ports/545278

Log:
  - Fix the build with -fno-common (clang 11 and gcc 10)
  - GC no longer useful patching of ${WRKSRC}/Makefile.in

  PR:	248729, 248734

Changes:
  head/databases/gdbm/Makefile