Bug 248739 - net/isc-dhcp44-server: Fix build with -fno-common (clang 11 and gcc 10)
Summary: net/isc-dhcp44-server: Fix build with -fno-common (clang 11 and gcc 10)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Ryan Steinmetz
URL:
Keywords:
Depends on:
Blocks: 248756
  Show dependency treegraph
 
Reported: 2020-08-18 21:11 UTC by Dimitry Andric
Modified: 2020-09-03 19:03 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (zi)
koobs: merge-quarterly?


Attachments
Fix build with -fno-common (clang 11 and gcc 10) (3.01 KB, patch)
2020-08-18 21:11 UTC, Dimitry Andric
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitry Andric freebsd_committer 2020-08-18 21:11:49 UTC
Created attachment 217324 [details]
Fix build with -fno-common (clang 11 and gcc 10)

In base r364284, I imported clang 11 into head. Like gcc 10, it now defaults to -fno-common, meaning that duplicated global symbols will most likely lead to link errors. Here is a patch to fix this port's duplicated global symbols.
Comment 1 Ryan Steinmetz freebsd_committer freebsd_triage 2020-08-18 23:23:26 UTC
Thanks!  I've submitted this upstream and will commit shortly.
Comment 2 Yasuhiro KIMURA 2020-09-03 17:46:36 UTC
The problem is fixed with ports r546952. So please close this bug report now.