Bug 248842 - sysutils/zfsnap2 fails to build if BASH or ZSH option is switched off
Summary: sysutils/zfsnap2 fails to build if BASH or ZSH option is switched off
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-23 07:10 UTC by Alexey Markov
Modified: 2020-11-09 17:53 UTC (History)
3 users (show)

See Also:
pi: maintainer-feedback-


Attachments
Patch for pkg-plist (498 bytes, patch)
2020-08-23 07:10 UTC, Alexey Markov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Markov 2020-08-23 07:10:06 UTC
Created attachment 217450 [details]
Patch for pkg-plist

Port installation fails if BASH or ZSH option is switched off because of missed parts in the pkg-plist file. Patch is attached.
Comment 1 Henrik Hudson 2020-08-25 14:51:55 UTC
I can confirm this issue. The provided patch fixes the issue. Thanks.
Comment 2 Miroslav Lachman 2020-11-09 15:31:16 UTC
Can somobody commit this fix, please?
Comment 3 Kurt Jaeger freebsd_committer 2020-11-09 17:53:35 UTC
Committed, thanks!
Comment 4 commit-hook freebsd_committer 2020-11-09 17:53:36 UTC
A commit references this bug:

Author: pi
Date: Mon Nov  9 17:53:26 UTC 2020
New revision: 554783
URL: https://svnweb.freebsd.org/changeset/ports/554783

Log:
  sysutils/zfsnap2: fix build if BASH or ZSH option is switched off

  PR:		248842
  Submitted by:	Alexey Markov <redrat@mail.ru>
  Reviewed by:	Henrik Hudson <ports@thelanman.net>, Miroslav Lachman <000.fbsd@quip.cz>
  Approved by:	mm (maintainer timeout)

Changes:
  head/sysutils/zfsnap2/pkg-plist