Bug 248887 - comms/xastir: update to 2.1.6
Summary: comms/xastir: update to 2.1.6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Diane Bruce
URL: https://github.com/Xastir/Xastir/rele...
Keywords: needs-patch
: 249494 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-08-24 18:20 UTC by russo
Modified: 2020-09-25 15:27 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (carl)


Attachments
svn diff to update to 2.1.6 (3.04 KB, patch)
2020-09-21 08:23 UTC, carl
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description russo 2020-08-24 18:20:20 UTC
Xastir 2.1.6 was released in April of 2020.  

FreeBSD's port still has 2.1.4 (over a year old), and that port was recently patched to fix the build with GCC 10 by adding "-fcommon" to the CFLAGS.  Xastir 2.1.6 has had its GCC 10 compatibility fixed so that sort of hack is no longer needed in the port if it were updated to the new version.  

There are also numerous other improvements over 2.1.4, including removal of obsolete options, and consolidation of some options that had previously been set up as independently selectable, but were in fact completely dependent on each other.  The build is simpler now, as some of these things that were previously user-selectable are automatic now -- notably, if shapelib support is requested and shapelib is found, pcre is also required *and* automatically enables dbfawk. The code that previously allowed shapelib support without dbfawk (and therefore pcre) has been removed.

This means that the current Makefile, which has no option for deselecting shapelib, but does have an option for selecting or deselecting DBFAWK, needs a little changing:  remove DBFAWK as an option and make pcre a required package along with shapelib (instead of dependent on the DBFAWK setting) and all should be well.


See: https://github.com/Xastir/Xastir/releases/tag/Release-2.1.6 for release notes.
Comment 1 carl 2020-09-21 06:40:32 UTC
bug 249494 submitted to update xastir to 2.1.6.

Sorry it took so long Tom.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2020-09-21 07:15:37 UTC
(In reply to carl from comment #1)

Thanks Carl, Can you attach the patch provided in bug 249494 to this issue please.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2020-09-21 07:16:31 UTC
*** Bug 249494 has been marked as a duplicate of this bug. ***
Comment 4 carl 2020-09-21 08:23:21 UTC
Created attachment 218130 [details]
svn diff to update to 2.1.6