Bug 248925 - devel/libfmt: Use release archive
Summary: devel/libfmt: Use release archive
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias Kortkamp
URL: https://github.com/fmtlib/fmt/release...
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-26 09:18 UTC by daniel.engberg.lists
Modified: 2020-09-24 17:46 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (tobik)


Attachments
Patch for libfmt (1.23 KB, patch)
2020-08-26 09:18 UTC, daniel.engberg.lists
no flags Details | Diff
Patch for libfmt v2 (1.20 KB, patch)
2020-09-21 05:56 UTC, daniel.engberg.lists
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description daniel.engberg.lists 2020-08-26 09:18:33 UTC
Update libfmt to 7.0.3
Use release archive instead of pulling source from GitHub repo as suggested by 5.4.3 in Porter's Handbook

Tested on FreeBSD 13.0-CURRENT #0 r358620 (AMD64) (make test)
Poudriere OK 12.1-RELEASE (AMD64)
Comment 1 daniel.engberg.lists 2020-08-26 09:18:57 UTC
Created attachment 217533 [details]
Patch for libfmt
Comment 2 daniel.engberg.lists 2020-09-07 22:12:02 UTC
Friendly ping
Comment 3 Rene Ladan freebsd_committer 2020-09-19 14:24:17 UTC
Steal from Tobias
Comment 4 Rene Ladan freebsd_committer 2020-09-19 14:29:42 UTC
Oh oops, Tobias committed an update in the meantime. Back to him.
Comment 5 daniel.engberg.lists 2020-09-21 05:56:26 UTC
Created attachment 218127 [details]
Patch for libfmt v2

Refresh patch, use release archive instead of GitHub.
Comment 6 Tobias Kortkamp freebsd_committer 2020-09-24 17:46:04 UTC
Release archive has files we don't need and is much larger, so that's why
the port doesn't use it.  Normally I like to use release archives when
possible but for fmt it IMHO doesn't provide any benefit.  I'd like
the reason for changing it to be more than "this is suggested in the
handbook" too.