Bug 248954 - mail/fetchmail: update to 6.4.10
Summary: mail/fetchmail: update to 6.4.10
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Matthias Andree
URL: https://sourceforge.net/projects/fetc...
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-27 20:47 UTC by Matthias Andree
Modified: 2020-09-21 16:19 UTC (History)
2 users (show)

See Also:
chalpin: maintainer-feedback+


Attachments
patch to update from fetchmail[conf] 6.4.8 to 6.4.10 (3.60 KB, patch)
2020-08-27 20:47 UTC, Matthias Andree
chalpin: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Andree freebsd_committer 2020-08-27 20:47:14 UTC
Created attachment 217577 [details]
patch to update from fetchmail[conf] 6.4.8 to 6.4.10

Hi Corey,

I am offering a patch to update fetchmail to 6.4.10. (6.4.9 was skipped due to a configure[.ac] regression.) It adds a Romanian translation and a minor man page fix to mention the fingerprint is an MD5 hash.

While here, it updates the files/patch-ZZZ* patch to patch the right place of the NEWS file with our local fix, and switches from lzip to xz since it appears that xz is more popular, we have it in the base system, and it does not make a real difference compression-wise. 6.5 will also use xz.

It builds OK (poudriere bulk -t) in my Poudriere systems:

11.3 i386
11.3 amd64
12.1 i386
12.1 amd64
12.1 mips64 (only fetchmail: fetchmailconf lacks Python 3 because it wants GCC 9 by means of libffi)
12.1 arm64 (aka aarch64).
Comment 1 Fernando Apesteguía freebsd_committer 2020-08-28 08:07:45 UTC
^Triage: Reporter is committer, assign accordingly.

Thanks!
Comment 2 Corey Halpin 2020-08-28 14:10:20 UTC
Comment on attachment 217577 [details]
patch to update from fetchmail[conf] 6.4.8 to 6.4.10

Looks good to me, works in my testing. Thank you!
Comment 3 Matthias Andree freebsd_committer 2020-08-28 14:42:20 UTC
Thank you.
Comment 4 commit-hook freebsd_committer 2020-08-28 14:42:27 UTC
A commit references this bug:

Author: mandree
Date: Fri Aug 28 14:42:14 UTC 2020
New revision: 546739
URL: https://svnweb.freebsd.org/changeset/ports/546739

Log:
  mail/fetchmail: update to 6.4.10

  while here, switch distfile back to xz format and update
  the > 2^31 "long long" fix so it patches the right place of the NEWS file.

  - adds Romanian translation
  - minor manual page fix to add "MD5" hash to sslfingerprint documentation

  PR:		248954
  Approved by:	Corey Halpin (maintainer)

Changes:
  head/mail/fetchmail/Makefile
  head/mail/fetchmail/distinfo
  head/mail/fetchmail/files/patch-ZZZ-87626c2707cc0d82e49e160ab3c85430ff33534f
  head/mail/fetchmail/pkg-plist
  head/mail/fetchmailconf/Makefile
Comment 5 commit-hook freebsd_committer 2020-09-21 16:19:13 UTC
A commit references this bug:

Author: mandree
Date: Mon Sep 21 16:18:26 UTC 2020
New revision: 549455
URL: https://svnweb.freebsd.org/changeset/ports/549455

Log:
  MFH: r546739 r547549

  mail/fetchmail: update to 6.4.12 (from 6.4.8)

  (Note this isn't the usual MFH changelog as that doesn't make sense in this
  particular case; head/ had some churn around a regression in 6.4.10 that
  this MFH-of-two-changeset nicely skips over.)

  Add: Romanian-language translation by Florentina Musat

  Add: manual page now mentions that --sslfingerprint hash is of MD5 type.

  Fix: README contained NEWS fragments (broken since c. 1 year/c. 6.4.2,
  fixed in 6.4.12) instead of the actual contents.

  Update: the > 2^31 "long long" local patch so it patches the right place of the
  NEWS file.

  PR:		248954
  Approved by:	Corey Halpin (maintainer)

  PR:		249009
  Approved by:	Corey Halpin (maintainer)

  Approved by:	ports-secteam@ (fluffy@)

Changes:
_U  branches/2020Q3/
  branches/2020Q3/mail/fetchmail/Makefile
  branches/2020Q3/mail/fetchmail/distinfo
  branches/2020Q3/mail/fetchmail/files/patch-ZZZ-87626c2707cc0d82e49e160ab3c85430ff33534f
  branches/2020Q3/mail/fetchmail/pkg-plist
  branches/2020Q3/mail/fetchmailconf/Makefile