Bug 248987 - print/scribus: icons are missing
Summary: print/scribus: icons are missing
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-29 11:46 UTC by probono
Modified: 2020-09-08 06:52 UTC (History)
1 user (show)

See Also:


Attachments
Missing icons in Scribus (264.55 KB, image/png)
2020-08-29 11:46 UTC, probono
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description probono 2020-08-29 11:46:50 UTC
Created attachment 217614 [details]
Missing icons in Scribus

All icons and other graphics are missing in Scribus. Possibly some dependencies have not been installed automatically?
Comment 1 probono 2020-08-29 11:48:42 UTC
scribus-devel 1.5.5_14 was installed with OctoPkg.
Comment 2 probono 2020-08-30 13:54:01 UTC
Seeing lots of:

Unable to load icon /usr/local/share/scribus/icons/1_5_1/vectorgfx.png:
Got null pixmap

The png file is there.
Comment 3 Max Brazhnikov freebsd_committer 2020-09-03 09:51:20 UTC
(In reply to probono from comment #0)
Probably graphics/qt5-imageformats is needed. Install it and try again
Comment 4 probono 2020-09-08 06:52:01 UTC
Looks like the icons themselves are broken.

doas pkg download scribus-devel
cd /tmp/pkg/
doas tar xfv scribus-devel-1.5.5_14.txz 
gimp usr/local/share/scribus/icons/1_5_1_dark/layer-outline.png

When trying to open one e.g., in GIMP, libpng gives:

png file corrupted by ASCII conversion