Bug 249062 - sysutils/nut: should create etc/syslog.d before copying file
Summary: sysutils/nut: should create etc/syslog.d before copying file
Status: Closed DUPLICATE of bug 241234
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Cy Schubert
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-02 13:25 UTC by Dan Langille
Modified: 2020-09-03 22:20 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (cy)


Attachments
creates etc/syslog.d, bumps PORTREVSION, and adds the directory to pkg-plist. (1.07 KB, patch)
2020-09-02 13:25 UTC, Dan Langille
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Langille freebsd_committer 2020-09-02 13:25:55 UTC
Created attachment 217704 [details]
creates etc/syslog.d, bumps PORTREVSION, and adds the directory to pkg-plist.

I notice this when installing sysutils/nut on a system which did not have a /usr/local/etc/syslog.d directory:

[2/2] Installing nut-2.7.4_14...
[2/2] Extracting nut-2.7.4_14: 100%
cp: /usr/local/etc/syslog.d/nut: No such file or directory
pkg: POST-INSTALL script failed
[dan@slocum:~] $ ls -l /usr/local/etc/syslog.d
ls: /usr/local/etc/syslog.d: No such file or directory
[dan@slocum:~] $ 


I could reproduce it via poudriere testport:

[121amd64-dvl] Extracting nut-2.7.4_14: 100%
cp: /usr/local/etc/syslog.d/nut: No such file or directory
pkg-static: POST-INSTALL script failed


The attached patch creates that directory, bumps PORTREVSION, and adds the directory to pkg-plist.

I'm happy to commit this on behalf of the maintainer if so wished.
Comment 1 Dan Langille freebsd_committer 2020-09-03 22:20:56 UTC

*** This bug has been marked as a duplicate of bug 241234 ***