Bug 249114 - devel/linux-c7-strace does not declare a dependency on elfutils
Summary: devel/linux-c7-strace does not declare a dependency on elfutils
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Edward Tomasz Napierala
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-04 18:26 UTC by Mark Johnston
Modified: 2020-10-14 16:44 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (trasz)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Johnston freebsd_committer 2020-09-04 18:26:24 UTC
I installed linux-c7-strace in a VM, and upon trying to use it got

/compat/linux/bin/strace: error while loading shared libraries: libdw.so.1: cannot open shared object file: No such file or directory

Installing linux-c7-elfutils-libs fixed the problem.
Comment 1 Edward Tomasz Napierala freebsd_committer 2020-10-14 16:44:12 UTC
Fixed in r547939 by eugen@.