Bug 249124 - net-mgmt/flow-tools failed to compile with all options turned off
Summary: net-mgmt/flow-tools failed to compile with all options turned off
Status: Closed DUPLICATE of bug 249388
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Muhammad Moinur Rahman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-05 08:25 UTC by Volodymyr Pushkar
Modified: 2020-09-25 08:41 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (bofh)


Attachments
port's Makefile patch (377 bytes, patch)
2020-09-05 08:25 UTC, Volodymyr Pushkar
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Volodymyr Pushkar 2020-09-05 08:25:52 UTC
Created attachment 217761 [details]
port's Makefile patch

flow-tools failed to compile due to postgresql dependency which is enabled by default even if not set in port options. 
Solution is to use --with-postgresql=no for configure when PGSQL is off.

Patch for the port's Makefile attached.
Comment 1 Volodymyr Pushkar 2020-09-23 07:12:03 UTC
*** Bug 249388 has been marked as a duplicate of this bug. ***
Comment 2 Muhammad Moinur Rahman freebsd_committer 2020-09-25 08:41:01 UTC
Closing this one and working on the other one.

*** This bug has been marked as a duplicate of bug 249388 ***