Bug 249141 - new port graphics/blenderLTS28
Summary: new port graphics/blenderLTS28
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL: https://www.blender.org/download/lts/
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-06 07:31 UTC by Shane
Modified: 2020-09-09 11:36 UTC (History)
1 user (show)

See Also:


Attachments
new port graphics/blenderLTS28 (179.90 KB, text/plain)
2020-09-06 07:31 UTC, Shane
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shane 2020-09-06 07:31:30 UTC
Created attachment 217785 [details]
new port graphics/blenderLTS28

Create new port for graphics/blenderLTS28 starting at v2.83.5
This is the first long term support release from blender
Critical bug fixes will be received for the next two years.
Files have been renamed to allow concurrent install with normal blender port
Comment 1 Li-Wen Hsu freebsd_committer 2020-09-08 16:59:30 UTC
How about calling it graphics/blender-lts? (Set PKGNAMESUFFIX=-lts) And we can rename it to graphics/blender-lts28 when we want to add more lts versions.
Comment 2 Shane 2020-09-09 11:36:26 UTC
I went with the uppercase following how blender promotes it on their site. Among ports keeping it all lower case is more common. Not real fussed either way on case.

I would rather keep the version from the start rather than changing it next year, we know there will be two LTS versions by mid next year. Trailing versions is common in other multi-version ports, like python, llvm, gcc

Not sure about adding the "-", it is used to separate flavours in pkg names, for port names and version additions I see it would be more common to add the version without a separator.