Bug 249165 - archivers/rpm4: Packaging fails due to missing files
Summary: archivers/rpm4: Packaging fails due to missing files
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Rodrigo Osorio
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-07 11:06 UTC by Eirik Oeverby
Modified: 2021-05-26 23:22 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (rodrigo)


Attachments
archivers/rpm4 build log (313.26 KB, text/plain)
2020-09-07 11:06 UTC, Eirik Oeverby
no flags Details
Build log from latest attempt (246.42 KB, text/plain)
2020-11-28 22:00 UTC, Eirik Oeverby
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eirik Oeverby 2020-09-07 11:06:37 UTC
Created attachment 217799 [details]
archivers/rpm4 build log

Building rpm4 package using poudriere fails with ~66 failures of the following kind.

Port configuration has all boxes ticketd; DOCS NLS PLUGINS and PYTHON. Various combinations of these make no discernible difference. Full build log attached.

===>  Building package for rpm4-4.15.1_2
pkg-static: Unable to access file /wrkdirs/usr/ports/archivers/rpm4/work/stage/usr/local/lib/rpm/platform/aarch64-freebsd/macros:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/archivers/rpm4/work/stage/usr/local/lib/rpm/platform/alpha-freebsd/macros:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/archivers/rpm4/work/stage/usr/local/lib/rpm/platform/alphaev5-freebsd/macros:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/archivers/rpm4/work/stage/usr/local/lib/rpm/platform/alphaev56-freebsd/macros:No such file or directory
Comment 1 Rodrigo Osorio freebsd_committer 2020-10-26 10:15:18 UTC
Can't reproduce in my poudriere.
Close this issue since we are now moving to 4.16.0

Don't hesitate to reopen the issue if you have more information to provide
Comment 2 Eirik Oeverby 2020-10-30 00:48:51 UTC
Sorry to be a bother - but even 4.16 fails to build.
What can I do to provide useful information about the failure?
Comment 3 Rodrigo Osorio freebsd_committer 2020-10-30 22:21:17 UTC
(In reply to Eirik Oeverby from comment #2)

Poudriere details: jails version & options activated
I assume you uses the latest version of the port
Comment 4 Eirik Oeverby 2020-11-28 22:00:46 UTC
Created attachment 220050 [details]
Build log from latest attempt

Latest version of port, this has been a problem for most of this year, at least. Perhaps longer.

Which options I choose does not change the outcome. The attached log (latest attempt) is with no options chosen at all (all disabled).
Comment 5 Eirik Oeverby 2021-05-26 23:22:02 UTC
Can you please tell me which poudriere version(s) this has been tested with, if there's anything special with working poudriere config, etc.? I've reproduced this on two different poudriere installations, and it has been a problem for a long time now - even with latest port version.