Bug 249283 - deskutils/py-vobject: needs devel/py-pytz dependency
Summary: deskutils/py-vobject: needs devel/py-pytz dependency
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Danilo G. Baio
URL:
Keywords:
: 249155 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-09-12 19:28 UTC by Michael Bueker
Modified: 2020-09-13 16:40 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Bueker 2020-09-12 19:28:32 UTC
After installing and starting www/radicale, the daemon spouts errors: "No module named 'pytz'".

Installing devel/py-pytz resolved those errors. As discussed in https://github.com/Kozea/Radicale/issues/816, it should be regarded a dependency of vobject.

Also compare #249155 for the same discussion as relates to www/radicale.
Comment 1 Danilo G. Baio freebsd_committer 2020-09-13 15:08:32 UTC
`make test` results.

Before:
  Ran 39 tests in 0.199s
  OK (skipped=1)

With devel/py-pytz:
  Ran 39 tests in 20.161s
  OK
Comment 2 commit-hook freebsd_committer 2020-09-13 15:08:59 UTC
A commit references this bug:

Author: dbaio
Date: Sun Sep 13 15:08:18 UTC 2020
New revision: 548480
URL: https://svnweb.freebsd.org/changeset/ports/548480

Log:
  deskutils/py-vobject: Add missing dependency

  This fixes issues with other ports that needs py-vobject.

  pytz is optional, but it doesn't make any harm having it as default, just the
  opposite.

  PR:		249283
  Reported by:	Michael Bueker <m.bueker@berlin.de>
  Approved by:	portmgr (blanket: runtime fix)

Changes:
  head/deskutils/py-vobject/Makefile
Comment 3 Danilo G. Baio freebsd_committer 2020-09-13 15:09:42 UTC
Committed, thanks!
Comment 4 Michael Bueker 2020-09-13 16:40:01 UTC
*** Bug 249155 has been marked as a duplicate of this bug. ***