Bug 249319 - x11-toolkits/vte3: fail to build "Dependency fribidi found: NO found 0.19.7 but need: '>=1.0.0'"
Summary: x11-toolkits/vte3: fail to build "Dependency fribidi found: NO found 0.19.7 b...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Loïc Bartoletti
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-14 15:44 UTC by VVD
Modified: 2020-09-14 19:23 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description VVD 2020-09-14 15:44:05 UTC
This version of vte3 require fribidi >= 1.0.0:

Dependency fribidi found: NO found 0.19.7 but need: '>=1.0.0'
Found CMake: /usr/local/bin/cmake (3.18.2)
Using 'CMAKE_PREFIX_PATH' from environment with value: '/usr/local'
Using 'LDFLAGS' from environment with value: ' -fstack-protector-strong '
Run-time dependency fribidi found: NO (tried cmake)

meson.build:414:2: ERROR: Invalid version of dependency, need 'fribidi' ['>=1.0.0'] found '0.19.7'.

A full log can be found at /tmp/work/usr/ports/x11-toolkits/vte3/work/vte-0.60.3/_build/meson-logs/meson-log.txt
===>  Script "configure" failed unexpectedly.
Please report the problem to gnome@FreeBSD.org [maintainer] and attach the
"/tmp/work/usr/ports/x11-toolkits/vte3/work/vte-0.60.3/_build/meson-logs/meson-log.txt"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
===========================================================================

There is fribidi 1.0.10 already: https://github.com/fribidi/fribidi/releases
But a lot of ports depends on it.

FriBidi Version 1.0.0
@dov dov released this on 4 Feb 2018 · 122 commits to master since this release
Version 1.0.0 of FriBidi is a major update that adds support for all the changes to the Unicode Bidirectional Algorithm that were introduced in UAX#9, version 6.3, and beyond. This library contains test code that validates the algorithm against the test-files provided by the Unicode consortium, and have been verified to be 100% compliant with version 10 of the unicode algorithm. Because of changes to the algorithm, the previous API have been deprecated in favor of a new API that introduces another couple of parameters. But the old API has been retained, and will return the same results as before these algorithmic changes.

Look like it's compatible.
Comment 1 Tobias C. Berner freebsd_committer 2020-09-14 16:21:25 UTC
Moin moin 

Thanks for the report -- this looks like the upgrade should have included an update of converters/fribidi, but was forgot in the final commit.


mfg Tobias
Comment 2 commit-hook freebsd_committer 2020-09-14 19:22:19 UTC
A commit references this bug:

Author: lbartoletti
Date: Mon Sep 14 19:22:03 UTC 2020
New revision: 548675
URL: https://svnweb.freebsd.org/changeset/ports/548675

Log:
  x11-toolkits/vte3: revert update to 0.60.3

  vte3 requires fribidi>=1.0.0 I forgot to push it with the update of vte3.

  BTW, an exp-run for fribidi has been requested (PR #228876). In the meantime, I revert my commit.

  PR:	249319
  Reported by:	VVD

Changes:
  head/x11-toolkits/vte3/Makefile
  head/x11-toolkits/vte3/distinfo
  head/x11-toolkits/vte3/pkg-plist
Comment 3 Loïc Bartoletti freebsd_committer 2020-09-14 19:23:34 UTC
I'll be back after bug #228876
Comment 4 Loïc Bartoletti freebsd_committer 2020-09-14 19:23:46 UTC
Thanks VVD!