Bug 249323 - ports-mgmt/pkg audit -F Segmentation fault - 1.15.1, regression
Summary: ports-mgmt/pkg audit -F Segmentation fault - 1.15.1, regression
Status: Closed DUPLICATE of bug 249166
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-pkg (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-14 17:49 UTC by Alan Somers
Modified: 2020-09-14 17:53 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (pkg)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Somers freebsd_committer 2020-09-14 17:49:45 UTC
pkg 1.15.1 crashes reliably during "pkg audit -F":

$ pkg audit -F
Fetching vuln.xml.bz2:   0%Child process pid=53558 terminated abnormally: Segmentation fault

Here's a stack trace from GDB:
(gdb) bt
#0  0x0000000800cc1e4e in fread_unlocked () from /lib/libc.so.7
#1  0x0000000800cc1db3 in fread () from /lib/libc.so.7
#2  0x00000000005002bc in pkg_fetch_file_to_fd (repo=0x0, 
    url=0x800fba0f0 "http://vuxml.freebsd.org/freebsd/vuln.xml.bz2", dest=5, t=0x7fffffffd798, 
    offset=0, size=-1, silent=false) at fetch.c:302
#3  0x00000000004ffa82 in pkg_fetch_file_tmp (repo=0x0, 
    url=0x800fba0f0 "http://vuxml.freebsd.org/freebsd/vuln.xml.bz2", 
    dest=0x7fffffffd920 "/tmp/vuln.xml.bz2.N5kBf2cN", t=0) at fetch.c:112
#4  0x000000000047bfa2 in pkg_audit_fetch (
    src=0x800fba0f0 "http://vuxml.freebsd.org/freebsd/vuln.xml.bz2", dest=0x0)
    at pkg_audit.c:276
#5  0x00000000002adc00 in exec_audit (argc=0, argv=0x7fffffffe5b0) at audit.c:164
#6  0x00000000002bbde9 in main (argc=2, argv=0x7fffffffe5a0) at main.c:886
Comment 1 Steve Wills freebsd_committer 2020-09-14 17:53:09 UTC

*** This bug has been marked as a duplicate of bug 249166 ***