Bug 249325 - bectl: missing flag in the help message
Summary: bectl: missing flag in the help message
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: Luca Pizzamiglio
URL: https://reviews.freebsd.org/D26429
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-14 21:58 UTC by Luca Pizzamiglio
Modified: 2020-10-30 22:09 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luca Pizzamiglio freebsd_committer 2020-09-14 21:58:46 UTC
In bectl, the -o flag in the destroy subcommand is missing the help message.
However it works and it's also documented in the man page
Comment 1 Kyle Evans freebsd_committer 2020-10-30 13:11:40 UTC
Submitter is a committer, patch is accepted and OK for commit-
Comment 2 commit-hook freebsd_committer 2020-10-30 19:37:43 UTC
A commit references this bug:

Author: pizzamig
Date: Fri Oct 30 19:37:34 UTC 2020
New revision: 367183
URL: https://svnweb.freebsd.org/changeset/base/367183

Log:
  bectl(8): missing flag in the help message

  Flag -o for destroy subcommand is missing in the help message,
  but present in the man page. Fix it.

  PR:		249325
  Approved by:	kevans
  Differential Revision:	https://reviews.freebsd.org/D26429

Changes:
  head/sbin/bectl/bectl.c
Comment 3 Luca Pizzamiglio freebsd_committer 2020-10-30 22:09:20 UTC
Committed!