Bug 249409 - www/firefox: 80.0.1 crashes when trying to save files
Summary: www/firefox: 80.0.1 crashes when trying to save files
Status: Closed DUPLICATE of bug 249290
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-gecko (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-17 20:05 UTC by J. B.
Modified: 2020-09-25 14:48 UTC (History)
3 users (show)

See Also:
jbeich: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description J. B. 2020-09-17 20:05:36 UTC

    
Comment 1 J. B. 2020-09-17 20:10:47 UTC
  After the pkg update amd64 12.1 stable, firefox and another libxul.so
based browser still function EXCEPT for immediate crash if attempting
to save files. 
"dbus-launch firefox" bought up multiple save dialogs which froze firefox.
Restoring a prior libxul.so moved the error from a a core 
dump to a segmentation fault.
............................................
this may be due to the other 10-odd desktop-related ports which
were simultaneously updated, but unfortunately I did not
catch the list so cannot comment on that.  In other words,
some other port other than firefox that was updated today
may be at fault.  Unsure.
..................................................
otter-browser is sufficing meanwhile for critical downloads.
Comment 2 J. B. 2020-09-17 20:30:24 UTC
seems to be # 249290, the cairo bug...
Comment 3 J. B. 2020-09-17 21:03:17 UTC
Rebuilt cairo.  Firefox now saves files.
Seamonkey, though, freezes...
Comment 4 J. B. 2020-09-17 21:18:59 UTC
Seamonkey fixed by deleting 
gvfs-* dbus-* orbit-root/* and another from /tmp...
So AFAIK this fixes this bug.
Comment 5 D. D. 2020-09-19 11:51:00 UTC
Can confirm rebuilding cairo fixed it for me too.
Comment 6 Jan Beich freebsd_committer 2020-09-25 14:48:40 UTC
Tracking as duplicate to help future cairo updates.

*** This bug has been marked as a duplicate of bug 249290 ***